summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2018-09-21 12:18:48 +0900
committerGordian Edenhofer2018-09-21 12:18:48 +0900
commitac4ad4a016ba1886ace56fd43f0303a306e51b19 (patch)
tree9217e78add8d3c6faaa870e5f47a3b86d0347ab5
parentb993177d837f4bf4312668109e3169cc7c6a45fd (diff)
downloadaur-ac4ad4a016ba1886ace56fd43f0303a306e51b19.tar.gz
upgpkg: minecraft-server 1.13.1-1
Broaden the scope of the regex which searches for active users in the minecraftd.sh management script to include more escape sequences. This notably enables using the idle_server part of the script in combination with the 'Paper' minecraft server. upgpkg: cuberite 1.12b975-2 upgpkg: spigot 1.12.2+b73-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xminecraftd.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fde68b3e395..209db90fa4ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,6 +29,6 @@ pkgbase = minecraft-server
sha512sums = 19ee3646bfbace353b65c0373594edb654de11c9671f29cebad3b31109f29f94ade1d529d9f409b0989c376bef9b451585b22a1e0ac4295fcc92d9565f808418
sha512sums = 5203f6331f740ecfcea2a2cc653603ae97419baa89e08512f9d8feb63e4a52978442a69b313eccd9037b676a62ab528e2b533c0fb95a9c7177318279fe0cde79
sha512sums = 73132ec613e05c8ed7ebe4eda2395f1ea0733ffe94ba7e203e06246d5852139bbfb7a9073b2b01891282339a2f85676699cd889cde79d6317066e27fd65b1d67
- sha512sums = b83b93a25d312825363eb85dec4b04379e9a3b2caf9faaf6f4958966900ecd2d2d5d8c5ecc25fca711da1dbf162129720bed419492ef8bf9dbb1649a5bdb1656
+ sha512sums = e52d87c381c490e21bad955f9a041a0e3677fc831b191a12297f36bba56fe5e31f0a1854cc36c464ed8d54535ec4c8f0f524a9fd757f2141fa0e7bb268f5b247
pkgname = minecraft-server
diff --git a/PKGBUILD b/PKGBUILD
index f2be4aecf7dd..1d60a75ae1c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ sha512sums=('a82805cc0b6ea0c3481405eef1910549623db9b025ff78d228ef9c767950b34d1e8
'19ee3646bfbace353b65c0373594edb654de11c9671f29cebad3b31109f29f94ade1d529d9f409b0989c376bef9b451585b22a1e0ac4295fcc92d9565f808418'
'5203f6331f740ecfcea2a2cc653603ae97419baa89e08512f9d8feb63e4a52978442a69b313eccd9037b676a62ab528e2b533c0fb95a9c7177318279fe0cde79'
'73132ec613e05c8ed7ebe4eda2395f1ea0733ffe94ba7e203e06246d5852139bbfb7a9073b2b01891282339a2f85676699cd889cde79d6317066e27fd65b1d67'
- 'b83b93a25d312825363eb85dec4b04379e9a3b2caf9faaf6f4958966900ecd2d2d5d8c5ecc25fca711da1dbf162129720bed419492ef8bf9dbb1649a5bdb1656')
+ 'e52d87c381c490e21bad955f9a041a0e3677fc831b191a12297f36bba56fe5e31f0a1854cc36c464ed8d54535ec4c8f0f524a9fd757f2141fa0e7bb268f5b247')
_game="minecraft"
_server_root="/srv/minecraft"
diff --git a/minecraftd.sh b/minecraftd.sh
index 521ac2cde882..139bf66fca19 100755
--- a/minecraftd.sh
+++ b/minecraftd.sh
@@ -86,10 +86,10 @@ is_player_online() {
# and since playernames may not contain this string the clean player-list can easily be retrieved.
# Otherwiese check the first digit after the last occurrence of "There are". If it is 0 then there
# are no players on the server. Should this test fail as well. Assume that a player is online.
- if [[ $(echo "${response}" | grep ":" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})?)?[m|K]//g' -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
+ if [[ $(echo "${response}" | grep ":" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g' -e 's/.*\: //' | tr -d '\n' | wc -c) -le 1 ]]; then
# No player is online
return 0
- elif [[ $(echo "${response}" | grep "There are" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})?)?[m|K]//g' -e 's/.*\: //' -e 's/^([^.]+).*$/\1/; s/^[^0-9]*([0-9]+).*$/\1/' | tr -d '\n') -eq 0 ]]; then
+ elif [[ $(echo "${response}" | grep "There are" | sed -r -e '$!d' -e 's/\x1B\[([0-9]{1,2}(;[0-9]{1,2})*)?[JKmsuG]//g' -e 's/.*\: //' -e 's/^([^.]+).*$/\1/; s/^[^0-9]*([0-9]+).*$/\1/' | tr -d '\n') -eq 0 ]]; then
# No player is online
return 0
else