summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Opyd2022-07-27 16:46:23 +0200
committerDominik Opyd2022-07-27 16:46:23 +0200
commitf898cbbb878bf7031f5a5c9a9ae5ccaf0f8688d9 (patch)
tree32f3add3bc03a800654ebc3b8b9ba31381a6e5b0
downloadaur-f898cbbb878bf7031f5a5c9a9ae5ccaf0f8688d9.tar.gz
release: darkpaintings 11.0.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa95aff9073b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = forge-server-darkpaintings
+ pkgdesc = This mod adds a large variety of new paintings to the game. These paintings are seamlessly integrated with the vanilla paintings and are placed in the world using the normal painting item.
+ pkgver = 11.0.2
+ pkgrel = 1
+ url = https://www.curseforge.com/minecraft/mc-mods/dark-paintings
+ arch = any
+ license = GPL
+ depends = forge-hooks>=1.0.0
+ depends = forge-server>=41.0.94
+ depends = forge-server-bookshelf>=14.1.7
+ noextract = DarkPaintings-Forge-1.19-11.0.2.jar
+ source = https://mediafiles.forgecdn.net/files/3823/331/DarkPaintings-Forge-1.19-11.0.2.jar
+ sha256sums = 91d5f5fc839f324362a5621147806b5bcec754d3a16d40f075865ec158a981ab
+
+pkgname = forge-server-darkpaintings
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb3fc1fa064c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dominik Opyd <d.opyd@oad.earth>
+
+pkgname=forge-server-darkpaintings
+modname=darkpaintings
+srvname=forge
+pkgver=11.0.2
+minver=1.19
+pkgrel=1
+
+url='https://www.curseforge.com/minecraft/mc-mods/dark-paintings'
+arch=('any')
+license=('GPL')
+pkgdesc="This mod adds a large variety of new paintings to the game. These paintings are seamlessly integrated with the vanilla paintings and are placed in the world using the normal painting item."
+
+source=(https://mediafiles.forgecdn.net/files/3823/331/DarkPaintings-Forge-1.19-11.0.2.jar)
+depends=("forge-hooks>=1.0.0"
+ "forge-server>=41.0.94"
+ "forge-server-bookshelf>=14.1.7")
+noextract=(DarkPaintings-Forge-$minver-$pkgver.jar)
+sha256sums=('91d5f5fc839f324362a5621147806b5bcec754d3a16d40f075865ec158a981ab')
+
+package() {
+ install -Dm 2755 $srcdir/DarkPaintings-Forge-$minver-$pkgver.jar $pkgdir/srv/$srvname/mods/$modname.jar
+}