summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-05 16:01:53 -0600
committerLuis Martinez2021-03-05 16:01:53 -0600
commitbf4de31c9282c60d02b99f739ab7d68014ac8375 (patch)
tree00dd55a9e3dcb9421c5315a9791802847a4e01df
parent50daaa732c5100303829279bcf727e06935a2971 (diff)
downloadaur-bf4de31c9282c60d02b99f739ab7d68014ac8375.tar.gz
add zsh install, bash instructions
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
-rw-r--r--forgit-git.install4
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c0caf90a046..801cd3ee924b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,13 +3,14 @@ pkgbase = forgit-git
pkgver = r273.c57c9f9
pkgrel = 1
url = https://github.com/wfxr/forgit
+ install = forgit-git.install
arch = any
groups = fish-plugins
groups = zsh-plugins
license = MIT
makedepends = git
+ depends = bash
depends = fzf
- optdepends = bash: supported shell
optdepends = zsh: supported shell
optdepends = fish: supported shell
optdepends = delta: human readable diffs
diff --git a/PKGBUILD b/PKGBUILD
index 79d2ea522180..b458e955ee91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,8 @@ arch=('any')
url="https://github.com/wfxr/forgit"
license=('MIT')
groups=('fish-plugins' 'zsh-plugins')
-depends=('fzf')
-optdepends=('bash: supported shell'
- 'zsh: supported shell'
+depends=('bash' 'fzf')
+optdepends=('zsh: supported shell'
'fish: supported shell'
'delta: human readable diffs'
'diff-so-fancy: human readable diffs'
@@ -19,6 +18,7 @@ optdepends=('bash: supported shell'
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
+install="$pkgname.install"
source=("git+$url")
md5sums=('SKIP')
@@ -30,9 +30,15 @@ pkgver() {
package() {
cd "$_pkgname"
+ # zsh install
+ install -Dm 644 forgit.plugin.zsh -t "$pkgdir/usr/share/zsh/plugins/$pkgname/"
+
# fish install
install -Dm 644 conf.d/forgit.plugin.fish "$pkgdir/etc/fish/conf.d/forgit.plugin.fish"
+ # docs
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+
# license
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/forgit-git.install b/forgit-git.install
new file mode 100644
index 000000000000..1d3f8a1ad8e1
--- /dev/null
+++ b/forgit-git.install
@@ -0,0 +1,4 @@
+post_install() {
+ printf ":: Bash users will need to source the scripts under\n"
+ printf ":: /usr/share/zsh/plugins/forgit.plugin.zsh to use this package.\n"
+}