summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-12 21:04:54 +0300
committerCaleb Maclennan2020-08-12 21:04:54 +0300
commit71be9c05e5c2fbc17a187ed7bd95b2aa4dcf2dd0 (patch)
tree5b8e286200be97ef73e80b68c48899476c00445f
downloadaur-format-1452-font.tar.gz
Initial upload: format-1452-font 1.000-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d04724a3a79e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = format-1452-font
+ pkgdesc = A typeface from Velvetyne without any optical corrections with a Din-like design
+ pkgver = 1.000
+ pkgrel = 1
+ url = https://velvetyne.fr/fonts/format-1452
+ arch = any
+ license = OFL
+ source = https://gitlab.com/velvetyne/format-1452/-/archive/4af715b8a873139975d2651f0e316604508635ff/format-1452-1.000.tar.bz2
+ sha256sums = 3c1e9805ffd5921bc51fb007e4539fd7a41fd7a5daf34f6bb1af5af3358cf2f4
+
+pkgname = otf-format-1452
+ provides = format-1452-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..947e9141a593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=format-1452
+pkgbase=$_name-font
+pkgname=(otf-$_name)
+_sha=4af715b8a873139975d2651f0e316604508635ff
+pkgver=1.000
+pkgrel=1
+pkgdesc='A typeface from Velvetyne without any optical corrections with a Din-like design'
+arch=('any')
+url="https://velvetyne.fr/fonts/$_name"
+license=('OFL')
+source=("https://gitlab.com/velvetyne/$_name/-/archive/$_sha/$_name-$pkgver.tar.bz2")
+sha256sums=('3c1e9805ffd5921bc51fb007e4539fd7a41fd7a5daf34f6bb1af5af3358cf2f4')
+
+package_otf-format-1452() {
+ provides=("$pkgbase")
+ cd "$_name-$_sha"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" fonts/otf/*.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
+}