summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas Iuri Medeiros Cabral2023-03-11 06:46:40 -0300
committerDouglas Iuri Medeiros Cabral2023-03-11 06:46:40 -0300
commit9e7c0b4ec56bc0a9b2fd607c370f15c508ddf0c1 (patch)
tree96420094ec7a099d45012db38e7b6bef8f56de26
parent6101818adeb230d5355c4365e0520ac3caf10bf9 (diff)
downloadaur-9e7c0b4ec56bc0a9b2fd607c370f15c508ddf0c1.tar.gz
Fixed pre_upgrade and pre_install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--forticlient-vpn.changelog5
-rw-r--r--forticlient-vpn.install6
4 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d471e624f31..f60a907b4ab2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = forticlient-vpn
pkgdesc = Build through the official package of FortiClient VPN only
pkgver = 7.0.7.0246
- pkgrel = 1
+ pkgrel = 2
url = https://www.fortinet.com/support/product-downloads
install = forticlient-vpn.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6611578e231b..a53c12b69515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Douglas Iuri Medeiros Cabral <douglasimcabral at zohomail dot com>
pkgname=forticlient-vpn
pkgver=7.0.7.0246
-pkgrel=1
+pkgrel=2
pkgdesc="Build through the official package of FortiClient VPN only"
arch=("x86_64")
url="https://www.fortinet.com/support/product-downloads"
@@ -27,6 +27,7 @@ package() {
install -Dm644 "${pkgdir}/lib/systemd/system/forticlient.service" "${pkgdir}/usr/lib/systemd/system/forticlient.service"
+ mkdir -p ${pkgdir}/var/lib/forticlient
rm -rf "${pkgdir}/lib"
# Install license
@@ -35,7 +36,6 @@ package() {
# Symbolic link to fortivpn CLI
mkdir -p ${pkgdir}/usr/bin
ln -sf '/opt/forticlient/fortivpn' "${pkgdir}/usr/bin/fortivpn"
- mkdir -p ${pkgdir}/var/lib/forticlient
}
diff --git a/forticlient-vpn.changelog b/forticlient-vpn.changelog
index 1e5ca366c9d6..71272d058f43 100644
--- a/forticlient-vpn.changelog
+++ b/forticlient-vpn.changelog
@@ -1,9 +1,12 @@
## forticlient-vpn - 7.0.7.0246 - 2023-03-09
+* forticlient-vpn - 7.0.7.0246 - `release 2`
+ + Fixed pre_upgrade and pre_install
+
+## forticlient-vpn - 7.0.7.0246 - 2023-03-09
* forticlient-vpn - 7.0.7.0246 - `release 1`
+ updated `PKGBUILD` and install scripts to support the new version 7.0.7.0246
+ added gzip to `depends`
-
## forticlient-vpn - 7.0.0.0018 - 2022-11-12
* forticlient-vpn - 7.0.0.0018 - `release 2`
+ updated install scripts
diff --git a/forticlient-vpn.install b/forticlient-vpn.install
index 8652af2e696a..3b99ad7a0353 100644
--- a/forticlient-vpn.install
+++ b/forticlient-vpn.install
@@ -23,6 +23,9 @@ pre_install () {
}
pre_upgrade () {
+
+ pre_install
+
# Check if forticlient is registered to EMS if it's an uninstall
if [ -f /opt/forticlient/.fct_ec_registered ] && [ "$action" != "upgrade" ]; then
echo "============================================================="
@@ -166,6 +169,9 @@ post_install() {
}
post_upgrade() {
+
+ post_install
+
cat << EOF
==> After upgrade, to restore your configuration, copy /etc/forticlient/.old/* to /etc/forticlient/