summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-11 19:49:24 +0300
committerDimitris Kiziridis2020-05-11 19:49:24 +0300
commit42cdc9c3e2651bca613ec1427847e413288d8b89 (patch)
tree3c73ce7ea8a5c7c915f5c22895115afc586a1901
parent003eaa2d401db39ce1e1211955bf98a337bca723 (diff)
downloadaur-42cdc9c3e2651bca613ec1427847e413288d8b89.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93cdcf625118..5503b632fc3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,12 +4,12 @@ pkgbase = fortio-bin
pkgrel = 1
url = https://fortio.org
arch = x86_64
- license = Apache-2.0
+ license = Apache
makedepends = tar
provides = fortio
noextract = fortio-bin-1.3.1
- source = fortio-bin-1.3.1::https://github.com/fortio/fortio/releases/download/v1.3.1/fortio-linux_x64-1.3.1.tgz
- md5sums = 9b9c93009f5a87174826031476db4887
+ source = fortio-bin-1.3.1.tgz::https://github.com/fortio/fortio/releases/download/v1.3.1/fortio-linux_x64-1.3.1.tgz
+ sha256sums = 07798ed244369be1cd8923ebb3831f2e170017300288fafad4c38009ecaa4627
pkgname = fortio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 487148709187..7064e8ff5eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@ pkgrel=1
pkgdesc='Fortio load testing library, command line tool, advanced echo server and web UI in go (golang). Allows to specify a set query-per-second load and record latency histograms and other useful stats'
arch=('x86_64')
url="https://fortio.org"
-license=('Apache-2.0')
+license=('Apache')
makedepends=('tar')
provides=('fortio')
noextract=("${pkgname}-${pkgver}")
-source=("${pkgname}-${pkgver}::https://github.com/fortio/fortio/releases/download/v${pkgver}/fortio-linux_x64-${pkgver}.tgz")
-md5sums=('9b9c93009f5a87174826031476db4887')
+source=("${pkgname}-${pkgver}.tgz::https://github.com/fortio/fortio/releases/download/v${pkgver}/fortio-linux_x64-${pkgver}.tgz")
+sha256sums=('07798ed244369be1cd8923ebb3831f2e170017300288fafad4c38009ecaa4627')
package() {
- cd "${srcdir}"
- tar xf $pkgname-$pkgver -C $pkgdir/
+ cd "${srcdir}"
+ tar xvf ${pkgname}-${pkgver}.tgz -C "${pkgdir}"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file