summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2019-06-10 00:31:37 +0200
committerMichael Lass2019-06-10 00:31:37 +0200
commit380addf16f647fbd49e8a0c81888ceb3d8c483fc (patch)
tree57e6b43f6ade8d71e2fd4099c37e79a3e86d4788
downloadaur-380addf16f647fbd49e8a0c81888ceb3d8c483fc.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..246ce0200793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fortran-language-server
+ pkgdesc = Fortran Language Server for the Language Server Protocol
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://github.com/hansec/fortran-language-server
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-argparse
+ depends = python-future
+ source = https://github.com/hansec/fortran-language-server/archive/v1.9.0.tar.gz
+ sha256sums = 6656190a73a1775f5bd289fce7c59da399e661d19fabea5a0ed13f3753f21ffd
+
+pkgname = fortran-language-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e5e172904d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Lass <bevan@bi-co.net>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
+
+pkgname=fortran-language-server
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="Fortran Language Server for the Language Server Protocol"
+arch=(any)
+url="https://github.com/hansec/fortran-language-server"
+license=('MIT')
+depends=(python-argparse python-future)
+makedepends=(python-setuptools)
+source=("https://github.com/hansec/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('6656190a73a1775f5bd289fce7c59da399e661d19fabea5a0ed13f3753f21ffd')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ # License
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}