summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-05-12 19:34:52 +0200
committerMichael Laß2023-05-12 19:38:29 +0200
commita26627e7296ff40db36be199e8debc36aaf91a78 (patch)
tree3fd547e729383f20a680dedd5cf73e0778a8c60f
parent10a76e63ff884030cf9a9b722dc3198cd4380557 (diff)
downloadaur-a26627e7296ff40db36be199e8debc36aaf91a78.tar.gz
Rm python-argparse as dep and warn about deprec.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fe3fcea188f..24d0e86310a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = fortran-language-server
pkgdesc = Fortran Language Server for the Language Server Protocol
pkgver = 1.12.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hansec/fortran-language-server
arch = any
license = MIT
- depends = python-argparse
depends = python-future
depends = python-setuptools
source = https://github.com/hansec/fortran-language-server/archive/v1.12.0.tar.gz
sha256sums = 5cda6341b1d2365cce3d80ba40043346c5dcbd0b35f636bfa57cb34df789ff17
pkgname = fortran-language-server
-
diff --git a/PKGBUILD b/PKGBUILD
index 3214d97b09c1..c5ca4436fce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,21 @@
pkgname=fortran-language-server
pkgver=1.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="Fortran Language Server for the Language Server Protocol"
arch=(any)
url="https://github.com/hansec/fortran-language-server"
license=('MIT')
-depends=(python-argparse python-future python-setuptools)
+depends=(python-future python-setuptools)
source=("https://github.com/hansec/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('5cda6341b1d2365cce3d80ba40043346c5dcbd0b35f636bfa57cb34df789ff17')
+prepare() {
+ COLOR_RED='\033[0;31m'
+ COLOR_NONE='\033[0m'
+ echo -e "${COLOR_RED}fortran-language-server is not maintained anymore. Consider switching to fortls.${COLOR_NONE}"
+}
+
build() {
cd "$pkgname-$pkgver"
python setup.py build