summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:14:57 +0200
committerMattias Andrée2015-07-08 18:14:57 +0200
commit277507956c8a43e5a3e0c23c9e2d397b3a4320ae (patch)
treeec8e9738f4a286530ce3d043759a307a64998980
downloadaur-277507956c8a43e5a3e0c23c9e2d397b3a4320ae.tar.gz
Initial import, version 1506171736
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..391273476295
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fortune-mod-americandad
+ pkgdesc = Fortune quotes from American Dad!
+ pkgver = 1506171736
+ pkgrel = 1
+ url = http://en.wikiquote.org/wiki/American_Dad!
+ arch = any
+ license = custom:cc-sa-3.0
+ makedepends = fortune-mod
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = grep
+ makedepends = wikiquote-fortune>=1.4
+ depends = fortune-mod
+ source = https://github.com/maandree/wikiquote-fortune-collection/archive/5.tar.gz
+ sha256sums = f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5
+
+pkgname = fortune-mod-americandad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4e4a7e59975
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-americandad
+pkgver=1506171736
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from American Dad!"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/American_Dad!")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=americandad SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/americandad
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- americandad americandad.dat "${pkgdir}/usr/share/fortune"
+}
+