summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilman Blumenbach2015-08-13 20:35:29 +0200
committerTilman Blumenbach2015-08-13 20:35:29 +0200
commit92a783e9511a0a70c5d5d213c04a74451dcec7d4 (patch)
treeb53895d07e229ee28b9cda0e2c568477248e963b
parent0019030d9812e0c845e66716fa6f383aca9c53d2 (diff)
downloadaur-92a783e9511a0a70c5d5d213c04a74451dcec7d4.tar.gz
pkgver() cannot generate abort the build on errors, so just show warnings.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccfedc2fd02b..8b42ea07d6d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fortune-mod-bofh-excuses
pkgdesc = BOFH excuses fortune cookie files
pkgver = 20121125.190600
- pkgrel = 1
+ pkgrel = 2
url = http://www.cs.wisc.edu/~ballard/bofh/
arch = any
groups = fortune-mods
diff --git a/PKGBUILD b/PKGBUILD
index 905071c25c4a..bde217ce0f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='fortune-mod-bofh-excuses'
pkgver=20121125.190600
-pkgrel=1
+pkgrel=2
pkgdesc='BOFH excuses fortune cookie files'
arch=('any')
url='http://www.cs.wisc.edu/~ballard/bofh/'
@@ -24,10 +24,11 @@ pkgver()
local lastmod=$(curl -fL -I "${_dlurl}" | tac | sed -n '/^Last-modified:[[:space:]]*/I { s///p; q }')
if [ -z "$lastmod" ]; then
- error "Could not determine time of last modification, see above for possible errors."
+ warning "Could not determine time of last modification, not updating pkgver."
+ return 1
fi
- date -ud "${lastmod}" '+%Y%m%d.%H%M%S'
+ date -ud "${lastmod}" '+%Y%m%d.%H%M%S' || { warning "Failed to generate pkgver, it will not be updated."; return 1; }
}
prepare()