summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2024-03-20 14:40:55 +0100
committerChristian Schendel2024-03-20 14:40:55 +0100
commit96fca0901565fc170532c9d125398d7dd3c5e8d7 (patch)
treefedf853b02b6d61ff8b51f75dc459fd4eb19e1a0
parentc9679b4b15ba79e2c17b114eec27fee433aa4ea6 (diff)
downloadaur-96fca0901565fc170532c9d125398d7dd3c5e8d7.tar.gz
Update 0.35 -> 0.36 and add choot
modified: .SRCINFO modified: .gitignore modified: PKGBUILD new file: chroot-build.sh
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD45
-rwxr-xr-xchroot-build.sh24
4 files changed, 53 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec9daaa59c97..5ebc60ea2f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fortune-mod-de
pkgdesc = Fortune Cookies in german, from the Debian project
- pkgver = 0.35
+ pkgver = 0.36
pkgrel = 1
url = https://packages.debian.org/source/sid/fortunes-de
arch = any
@@ -9,7 +9,7 @@ pkgbase = fortune-mod-de
depends = fortune-mod
provides = fortune-mod-de
conflicts = fortune-mod-de
- source = http://ftp.de.debian.org/debian/pool/main/f/fortunes-de/fortunes-de_0.35.orig.tar.gz
- md5sums = c3ff83748c0cf07f6265636a142a27ad
+ source = http://ftp.de.debian.org/debian/pool/main/f/fortunes-de/fortunes-de_0.36.orig.tar.gz
+ md5sums = 0a59881abb5af5d44be06c70ed91308f
pkgname = fortune-mod-de
diff --git a/.gitignore b/.gitignore
index b39f3b2a183f..1c9a864c9f3d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@
!PKGBUILD
!.gitignore
!.SRCINFO
+!chroot-build.sh
+
diff --git a/PKGBUILD b/PKGBUILD
index 6d0b7df1705e..41868c9a3881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,42 @@
# Maintainer: Christian Schendel < doppelhelix@gmail.com >
pkgname=fortune-mod-de
-pkgver=0.35
+pkgver=0.36
pkgrel=1
pkgdesc="Fortune Cookies in german, from the Debian project"
url="https://packages.debian.org/source/sid/fortunes-de"
-depends=('fortune-mod')
-makedepends=('recode')
+depends=(
+ 'fortune-mod'
+)
+makedepends=(
+ 'recode'
+)
source=(http://ftp.de.debian.org/debian/pool/main/f/fortunes-de/fortunes-de_$pkgver.orig.tar.gz)
arch=('any')
license=('GPL2')
-md5sums=('c3ff83748c0cf07f6265636a142a27ad')
+md5sums=('0a59881abb5af5d44be06c70ed91308f')
provides=("${pkgname}")
conflicts=("${pkgname}")
build() {
cd "$srcdir/fortunes-de-${pkgver}"
-
- PREFIX=`pwd`/build \
- DOCDIR=usr/share/doc/${pkgname%-git} \
- BINDIR=usr/bin \
- FORTUNESDIR=usr/share/fortune \
- ./install.sh -utf8
+ PREFIX=$(pwd)/build \
+ DOCDIR=usr/share/doc/${pkgname%-git} \
+ BINDIR=usr/bin \
+ FORTUNESDIR=usr/share/fortune \
+ ./install.sh -utf8
}
package() {
- cd "$srcdir/fortunes-de-${pkgver}/build"
- rm -r {man,usr/bin}
- cp -r * "${pkgdir}"
- # Remove *.u8 files and strip ".fortunes" from filenames
- cd $pkgdir/usr/share/fortune/de
- mv debian debian-de
- mv debian.dat debian-de.dat
- rm *.u8
- mv * ..
- cd ..
- rm -r de
+ cd "$srcdir/fortunes-de-${pkgver}/build"
+ rm -r {man,usr/bin}
+ cp -r * "${pkgdir}"
+ # Remove *.u8 files and strip ".fortunes" from filenames
+ cd $pkgdir/usr/share/fortune/de
+ mv debian debian-de
+ mv debian.dat debian-de.dat
+ rm *.u8
+ mv * ..
+ cd ..
+ rm -r de
}
diff --git a/chroot-build.sh b/chroot-build.sh
new file mode 100755
index 000000000000..f358a74acaaf
--- /dev/null
+++ b/chroot-build.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+# This script updates the package version if a new version is available
+set -euxo pipefail
+
+# Preparing arch-chroot
+CHROOT=$HOME/.local/share/chroot
+if [[ ! -d "$CHROOT" ]]; then
+ mkdir -p "$CHROOT"
+ mkarchroot "$HOME/.local/share/chroot/root" base-devel
+ arch-nspawn "$HOME/.local/share/chroot/root" pacman -Syu
+fi
+
+# Start generate package
+makechrootpkg -c -r "$CHROOT" -- -Acsf .
+
+# Update .SRCINFO
+#makepkg --printsrcinfo >.SRCINFO
+
+# Commit changes
+#git add PKGBUILD .SRCINFO
+#git commit -s -m "Update to ${VER}"
+#rm -rf *.gz *.log *.zst
+sudo rm -Rf "$CHROOT"