summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-05-18 16:29:46 +0200
committerStephan Springer2018-05-18 16:29:46 +0200
commit8984410ea7951398fb605b313f8d9d054dc6835c (patch)
tree319a06848d85feeab5f6f5f9be4b031cea5a68b4
parent33f9b32156439e8d619ab4653c409968cbc10778 (diff)
downloadaur-8984410ea7951398fb605b313f8d9d054dc6835c.tar.gz
fixed URL and source, shortened pkgver, added quotes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5167d902a428..2e1a711c3775 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = fortune-mod-fvl-git
pkgdesc = Fortune quotes by Felix von Leitner (Fefe)
- pkgver = 20150208.r4.5bcd5db
+ pkgver = r4.5bcd5db
pkgrel = 1
- url = https://github.com/yayachiken/_fortune-mod-fvl-git
+ url = https://github.com/yayachiken/fortune-mod-fvl
arch = any
license = GPL2
makedepends = git
depends = fortune-mod
- source = git://github.com/yayachiken/fortune-mod-fvl.git
+ source = git+https://github.com/yayachiken/fortune-mod-fvl.git
sha256sums = SKIP
pkgname = fortune-mod-fvl-git
diff --git a/PKGBUILD b/PKGBUILD
index 96861d5466fb..31eb48b3ce23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Stephan Springer <buzo+arch@Lini.de>
_pkgname=fortune-mod-fvl
-pkgname=$_pkgname-git
-pkgver=20150208.r4.5bcd5db
+pkgname="$_pkgname"-git
+pkgver=r4.5bcd5db
pkgrel=1
pkgdesc="Fortune quotes by Felix von Leitner (Fefe)"
-url="https://github.com/yayachiken/_$pkgname"
+url="https://github.com/yayachiken/$_pkgname"
arch=('any')
license=('GPL2')
depends=(fortune-mod)
makedepends=(git)
-source=(git://github.com/yayachiken/$_pkgname.git)
+source=(git+https://github.com/yayachiken/$_pkgname.git)
sha256sums=(SKIP)
pkgver() {
- cd $_pkgname
- printf "%s.r%s.%s" \
- "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" \
+ cd "$_pkgname"
+ printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
"$(git rev-parse --short HEAD)"
}
@@ -28,6 +27,6 @@ build() {
}
package(){
- mkdir -p ${pkgdir}/usr/share/fortune
- cp $_pkgname/fvl{,_vendor}{,.dat} ${pkgdir}/usr/share/fortune
+ mkdir -p "$pkgdir"/usr/share/fortune
+ cp "$_pkgname"/fvl{,_vendor}{,.dat} "$pkgdir"/usr/share/fortune
}