summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:17:12 +0200
committerMattias Andrée2015-07-08 18:17:12 +0200
commitf4c6a55f411109e236e4de4ff6801abc2d0ff257 (patch)
treee37546613b4f259bf2b5fbada5389e0efe9e52b7
downloadaur-f4c6a55f411109e236e4de4ff6801abc2d0ff257.tar.gz
Initial import, version 1507062202
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b8deb51211b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fortune-mod-mlpfim
+ pkgdesc = Fortune quotes from My Little Pony: Friendship is Magic
+ pkgver = 1507062202
+ pkgrel = 1
+ url = http://en.wikiquote.org/wiki/My_Little_Pony:_Friendship_is_Magic
+ arch = any
+ license = custom:cc-sa-3.0
+ makedepends = fortune-mod
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = grep
+ makedepends = wikiquote-fortune>=1.4
+ depends = fortune-mod
+ source = https://github.com/maandree/wikiquote-fortune-collection/archive/5.tar.gz
+ sha256sums = f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5
+
+pkgname = fortune-mod-mlpfim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b912ab15a52e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-mlpfim
+pkgver=1507062202
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from My Little Pony: Friendship is Magic"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/My_Little_Pony:_Friendship_is_Magic")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=mlpfim SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/mlpfim
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- mlpfim mlpfim.dat "${pkgdir}/usr/share/fortune"
+}
+