summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2015-07-13 03:20:40 +0200
committerVirtualTam2015-07-13 03:20:40 +0200
commit24434c7863ecfcdf1c1357354a16d379a5849318 (patch)
treeb45fc968a48c7cf339e186d84f7cd0ef306a8735
downloadaur-24434c7863ecfcdf1c1357354a16d379a5849318.tar.gz
Initial import of fortune-mod-protolol-git
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24d8718e40ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fortune-mod-protolol-git
+ pkgdesc = A compilation of networking jokes
+ pkgver = 9f59ff8
+ pkgrel = 1
+ url = http://attrition.org/misc/ee/protolol.txt
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = fortune-mod
+ source = git://github.com/virtualtam/fortune-protolol.git
+ sha256sums = SKIP
+
+pkgname = fortune-mod-protolol-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..214cf6fd39a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+pkgname=fortune-mod-protolol-git
+pkgver=9f59ff8
+pkgrel=1
+pkgdesc="A compilation of networking jokes"
+url="http://attrition.org/misc/ee/protolol.txt"
+arch=('i686' 'x86_64')
+license=('custom:WTFPL')
+depends=(fortune-mod)
+makedepends=(git)
+_gitname="fortune-protolol"
+source=(git://github.com/virtualtam/fortune-protolol.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ # Edit if you wish to change how strings are indexed
+ # man strfile for more information
+ strfile -r protolol
+}
+
+package(){
+ mkdir -p ${pkgdir}/usr/share/fortune
+ cp ${srcdir}/${_gitname}/protolol ${pkgdir}/usr/share/fortune
+ cp ${srcdir}/${_gitname}/protolol.dat ${pkgdir}/usr/share/fortune
+}