summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2016-03-04 10:16:50 +0100
committerÉtienne Deparis2016-03-04 10:16:50 +0100
commita2554b7baeee4cb14e0917ec92262ab15254d8e0 (patch)
tree326b7d3ed108bb9e0e657386e48a6f5f7741b23e
parent653efe882a06ab093db8673791107ceffb2d8f3e (diff)
downloadaur-a2554b7baeee4cb14e0917ec92262ab15254d8e0.tar.gz
Cleanup PKGBUILD and fold string to 80 chars
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef29f8175cf9..d088b14927ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
-# Generated by makepkg 4.2.1
-# Wed Jun 10 12:45:32 UTC 2015
+# Generated by makepkg 5.0.1
+# Fri Mar 4 09:16:02 UTC 2016
pkgbase = fortune-tontons-flingueurs-fr
pkgdesc = Fortune cookies from french movie Les Tontons Flingeurs
- pkgver = 20110606
+ pkgver = 20160304
pkgrel = 1
url = http://fr.wikiquote.org/wiki/Les_Tontons_flingueurs
- arch = i686
- arch = x86_64
+ arch = any
license = unknown
+ makedepends = coreutils
depends = fortune-mod
source = tontonsflingueurs
sha1sums = 2f8fe0fe837aa22e010989fe27e0801288965203
diff --git a/PKGBUILD b/PKGBUILD
index f327592bdc88..392b409f506d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=fortune-tontons-flingueurs-fr
-pkgver=20110606
+pkgver=20160304
pkgrel=1
pkgdesc="Fortune cookies from french movie Les Tontons Flingeurs"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://fr.wikiquote.org/wiki/Les_Tontons_flingueurs"
license=('unknown')
depends=('fortune-mod')
+makedepends=('coreutils')
source=(tontonsflingueurs)
sha1sums=('2f8fe0fe837aa22e010989fe27e0801288965203')
build() {
cd ${srcdir}
- strfile tontonsflingueurs tontonsflingueurs.dat
+ fold -w 80 -s tontonsflingueurs > tontonsflingueurs.folded || exit 1
+ strfile -r tontonsflingueurs.folded tontonsflingueurs.dat || exit 2
}
package() {
install -d ${pkgdir}/usr/share/fortune/fr
- install -m644 ${srcdir}/tontonsflingueurs* ${pkgdir}/usr/share/fortune/fr
+ install -m644 ${srcdir}/tontonsflingueurs.folded ${pkgdir}/usr/share/fortune/fr/tontonsflingueurs
+ install -m644 ${srcdir}/tontonsflingueurs.dat ${pkgdir}/usr/share/fortune/fr/tontonsflingueurs.dat
}