summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-03-27 12:04:20 +0000
committerEric Engestrom2019-03-27 12:04:20 +0000
commitd03431c9331a2df4dfdcd414acf7b388f5d0226d (patch)
tree1a930fe2bd3a3e4bdff311dca4078de5b64c3487
parent4ad408e26c5c3ec4109a6a02c9ec670e6e7f40f4 (diff)
downloadaur-d03431c9331a2df4dfdcd414acf7b388f5d0226d.tar.gz
replace package with fossilize-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD43
2 files changed, 14 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48e2325d033f..c72d8d343fa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = fossilize
pkgdesc = Library and Vulkan layer for serializing various persistent Vulkan objects which typically end up in hashmaps
- pkgver = 0.0.0+258.3921ae69e8
+ pkgver = 0
pkgrel = 1
url = https://github.com/ValveSoftware/Fossilize
arch = x86_64
license = MIT
- makedepends = rapidjson
- source = https://github.com/ValveSoftware/Fossilize
- sha256sums = SKIP
+ depends = fossilize
pkgname = fossilize
diff --git a/PKGBUILD b/PKGBUILD
index 4a57c18a9378..dff4201158c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,23 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=fossilize
-pkgver=0.0.0+258.3921ae69e8
+pkgver=0
pkgrel=1
pkgdesc="Library and Vulkan layer for serializing various persistent Vulkan objects which typically end up in hashmaps"
arch=(x86_64)
url="https://github.com/ValveSoftware/Fossilize"
license=(MIT)
-depends=()
-makedepends=(rapidjson)
-source=("git+$url")
-sha256sums=('SKIP')
-
-pkgver() {
- cd Fossilize
- printf '0.0.0+%d.%s' \
- $(git rev-list --count HEAD) \
- $(git rev-parse HEAD | head -c10)
-}
-
-build() {
- cd Fossilize
- git submodule update --init --recursive
- mkdir -p build
- cd build
- cmake .. \
- -DFOSSILIZE_RAPIDJSON_INCLUDE_PATH=/usr/include/rapidjson/ \
- -DCMAKE_BUILD_TYPE=Release
- make
-}
+depends=(fossilize-git)
package() {
- cd Fossilize/build
-
- install -dm755 "$pkgdir/usr/bin"
- install -m755 cli/fossilize-* "$pkgdir/usr/bin"
-
- install -dm755 "$pkgdir/usr/lib" "$pkgdir/usr/share/vulkan/explicit_layer.d"
- install -m755 layer/libVkLayer_fossilize.so "$pkgdir/usr/lib"
- install -m755 layer/VkLayer_fossilize.json "$pkgdir/usr/share/vulkan/explicit_layer.d"
+ msg2 ""
+ msg2 "---"
+ msg2 ""
+ msg2 "Fossilize does not have any release, this package was misnamed."
+ msg2 "In the mean time, please install \`fossilize-git\` instead."
+ msg2 "This package will be updated once Fossilize has its first release."
+ msg2 ""
+ msg2 "---"
+ msg2 ""
+ return 1
}