summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-03-18 11:08:13 +0100
committerJosip Ponjavic2019-03-18 11:08:13 +0100
commitcdbcf739659670fec20d42588fbbafc5e12d5819 (patch)
tree3e7576248abe05bba6e95ef445881aa14cfa71c6
parentc639bc2a5ed966bca6b6389c17981f47416ed8ee (diff)
downloadaur-cdbcf739659670fec20d42588fbbafc5e12d5819.tar.gz
add fotowall-1.0-fix-build-against-qt-5.11.0.patch from Mageia
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--fotowall-1.0-fix-build-against-qt-5.11.0.patch34
3 files changed, 50 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be577f5a6b8c..34ae06e06b24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = fotowall
pkgdesc = A creative tool that allows you to layout your photos or pictures in a personal way
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.enricoros.com/opensource/fotowall/
- arch = i686
arch = x86_64
license = LGPL3
+ makedepends = qt5-tools
depends = desktop-file-utils
depends = qt5-svg
source = fotowall-1.0.tar.gz::https://github.com/enricoros/fotowall/archive/v1.0.tar.gz
+ source = fotowall-1.0-fix-build-against-qt-5.11.0.patch
sha256sums = 8dc42262dd5220a12e92181ff82bd363a6506a4c3ab1ea3841281f2971e1b289
+ sha256sums = fa573efa3529939ca83d3dc96d49277fe4f5472978d7c8e119a147119ac4abb1
pkgname = fotowall
diff --git a/PKGBUILD b/PKGBUILD
index 4e3ab63f31ed..fd110ec471f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,22 @@
pkgname=fotowall
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A creative tool that allows you to layout your photos or pictures in a personal way"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.enricoros.com/opensource/fotowall/"
license=('LGPL3')
depends=('desktop-file-utils' 'qt5-svg')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/enricoros/fotowall/archive/v$pkgver.tar.gz")
-sha256sums=('8dc42262dd5220a12e92181ff82bd363a6506a4c3ab1ea3841281f2971e1b289')
+makedepends=('qt5-tools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/enricoros/fotowall/archive/v$pkgver.tar.gz"
+ "fotowall-1.0-fix-build-against-qt-5.11.0.patch")
+sha256sums=('8dc42262dd5220a12e92181ff82bd363a6506a4c3ab1ea3841281f2971e1b289'
+ 'fa573efa3529939ca83d3dc96d49277fe4f5472978d7c8e119a147119ac4abb1')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../fotowall-1.0-fix-build-against-qt-5.11.0.patch
+}
build() {
cd $pkgname-$pkgver
diff --git a/fotowall-1.0-fix-build-against-qt-5.11.0.patch b/fotowall-1.0-fix-build-against-qt-5.11.0.patch
new file mode 100644
index 000000000000..af839baa627f
--- /dev/null
+++ b/fotowall-1.0-fix-build-against-qt-5.11.0.patch
@@ -0,0 +1,34 @@
+diff -Nru a/3rdparty/likebackfrontend/LikeBackDialog.cpp b/3rdparty/likebackfrontend/LikeBackDialog.cpp
+--- a/3rdparty/likebackfrontend/LikeBackDialog.cpp 2017-07-09 10:22:44.000000000 +0200
++++ b/3rdparty/likebackfrontend/LikeBackDialog.cpp 2018-06-02 22:39:10.413838601 +0200
+@@ -37,6 +37,7 @@
+ #include "LikeBackDialog.h"
+
+ #include <QApplication>
++#include <QButtonGroup>
+ #include <QLocale>
+ #include <QMessageBox>
+ #include <QNetworkAccessManager>
+diff -Nru a/App/CanvasAppliance.cpp b/App/CanvasAppliance.cpp
+--- a/App/CanvasAppliance.cpp 2017-07-09 10:22:44.000000000 +0200
++++ b/App/CanvasAppliance.cpp 2018-06-02 22:27:06.246459699 +0200
+@@ -30,6 +30,7 @@
+ #include "Settings.h"
+ #include "Workflow.h"
+
++#include <QActionGroup>
+ #include <QDesktopWidget>
+ #include <QFileDialog>
+ #include <QInputDialog>
+diff -Nru a/App/CanvasAppliance.h b/App/CanvasAppliance.h
+--- a/App/CanvasAppliance.h 2017-07-09 10:22:44.000000000 +0200
++++ b/App/CanvasAppliance.h 2018-06-02 22:32:38.238990315 +0200
+@@ -15,6 +15,8 @@
+ #ifndef __CanvasAppliance_h__
+ #define __CanvasAppliance_h__
+
++#include <QActionGroup>
++
+ #include "Shared/PlugGui/AbstractAppliance.h"
+ #include "ui_CanvasAppliance.h"
+ class QMenu;