summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip2016-01-17 21:37:11 +0100
committerJosip2016-01-17 21:37:11 +0100
commit238e54d2e268dfdd2863b10a2e7fa2a10fba1403 (patch)
tree05ec9e3abb95481f112916bb875d26dc7748e343
downloadaur-238e54d2e268dfdd2863b10a2e7fa2a10fba1403.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
-rw-r--r--fotowall.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cf13a4c72a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 20:36:46 UTC 2016
+pkgbase = fotowall-git
+ pkgdesc = A creative tool that allows you to layout your photos or pictures in a personal way
+ pkgver = 0.98.beta.r17.g7b4b595
+ pkgrel = 1
+ url = https://github.com/enricoros/fotowall
+ install = fotowall.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = desktop-file-utils
+ depends = qt5-svg
+ provides = fotowall
+ conflicts = fotowall
+ source = git+https://github.com/enricoros/fotowall.git
+ md5sums = SKIP
+
+pkgname = fotowall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..470647a67669
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=fotowall-git
+pkgver=0.98.beta.r17.g7b4b595
+pkgrel=1
+pkgdesc="A creative tool that allows you to layout your photos or pictures in a personal way"
+arch=('i686' 'x86_64')
+url="https://github.com/enricoros/fotowall"
+license=('GPL2')
+depends=('desktop-file-utils' 'qt5-svg')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install="fotowall.install"
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-*}"
+ make INSTALL_ROOT="${pkgdir}/" install
+} \ No newline at end of file
diff --git a/fotowall.install b/fotowall.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/fotowall.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}