summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:14:42 +0200
committerStefan Husmann2015-06-09 00:14:42 +0200
commitd60a836b5fbeb3f2ac764a803dd78a6062cc002f (patch)
treea081085e5e53969d2e249252f6d2a175c7a3adae
downloadaur-d60a836b5fbeb3f2ac764a803dd78a6062cc002f.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
-rw-r--r--fotoxx.install9
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a1f7e671ffe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = fotoxx
+ pkgdesc = A program for improving image files made with a digital camera
+ pkgver = 15.06
+ pkgrel = 1
+ url = http://www.kornelix.com/fotoxx
+ install = fotoxx.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = xdg-utils
+ depends = dcraw
+ depends = gtk3
+ depends = gimp-ufraw
+ depends = perl-image-exiftool>=0.8.6
+ optdepends = mashup: for composing pages to print from within fotoxx
+ optdepends = brasero: for burning
+ source = http://www.kornelix.com/uploads/1/3/0/3/13035936/fotoxx-15.06.tar.gz
+ md5sums = 00f953443872fdc26a518aa6505b43f8
+
+pkgname = fotoxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..953e79f797a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=fotoxx
+pkgver=15.06
+pkgrel=1
+pkgdesc="A program for improving image files made with a digital camera"
+url="http://www.kornelix.com/fotoxx"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('dcraw' 'gtk3' 'gimp-ufraw' 'perl-image-exiftool>=0.8.6')
+makedepends=('xdg-utils')
+optdepends=('mashup: for composing pages to print from within fotoxx'
+ 'brasero: for burning')
+source=("http://www.kornelix.com/uploads/1/3/0/3/13035936/$pkgname-$pkgver.tar.gz")
+md5sums=('00f953443872fdc26a518aa6505b43f8')
+install=fotoxx.install
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's+xdg-deskto+#xdg-deskto+' Makefile
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ CXX=g++ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR=$pkgdir PREFIX=/usr install
+ chmod o+r "$pkgdir"/usr/share/fotoxx/data/{edit-menus-es,edit-menus-ca,KB-shortcuts-es,KB-shortcuts-ca}
+ rm -r "$pkgdir"/usr/share/appdata
+}
+
diff --git a/fotoxx.install b/fotoxx.install
new file mode 100644
index 000000000000..90156a79c622
--- /dev/null
+++ b/fotoxx.install
@@ -0,0 +1,9 @@
+post_install() {
+ update-desktop-database -q
+}
+post_update() {
+ update-desktop-database -q
+}
+post_remove() {
+ update-desktop-database -q
+}