summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-01-14 04:05:28 +0100
committerMuflone2018-01-14 04:05:28 +0100
commit7cc361e59011190cacbef0544eaf72064a22376c (patch)
tree5728429947e98b3b07b7eecd4da738fbb089acda
parent1402cc878a5dd31c616545ea371ed567f78d357d (diff)
downloadaur-7cc361e59011190cacbef0544eaf72064a22376c.tar.gz
Updated package foxitreader 2.4.1.0609-5
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD76
-rw-r--r--foxitreader-excluded_files-i686102
-rw-r--r--foxitreader-excluded_files-x86_6410
-rw-r--r--installer.qs45
5 files changed, 84 insertions, 171 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63bf2f9182d..b45f7139b55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,24 @@
# Generated by mksrcinfo v8
-# Sun Nov 19 00:04:57 UTC 2017
+# Sun Jan 14 03:03:42 UTC 2018
pkgbase = foxitreader
pkgdesc = A fast, secure and complete PDF viewer
pkgver = 2.4.1.0609
- pkgrel = 4
+ pkgrel = 5
url = https://www.foxitsoftware.com/products/pdf-reader/
- arch = i686
arch = x86_64
license = custom:EULA
- makedepends = qt-installer-framework>=3.0.1
- makedepends = qt5-tools
- makedepends = p7zip
depends = libsecret
depends = qt5-webkit
+ source = http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz
source = https://www.foxitsoftware.com/products/pdf-reader/eula.html
source = foxitreader.patch
+ source = foxitreader-excluded_files-x86_64
+ source = installer.qs
+ sha256sums = d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba
sha256sums = c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079
sha256sums = d85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1
- source_i686 = http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader2.4.1.0609_Server_x86_enu_Setup.run.tar.gz
- source_i686 = foxitreader-excluded_files-i686
- sha256sums_i686 = 03dd1c4d248bd1782a9a9dd46836ffec9f38128b5f34ad3370a71d33fd87c9bc
- sha256sums_i686 = 58addc465b629286552a9166ab70509c2f87bee9f7519dcd567a183f5dcaba9b
- source_x86_64 = http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz
- source_x86_64 = foxitreader-excluded_files-x86_64
- sha256sums_x86_64 = d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba
- sha256sums_x86_64 = 02d9bb529bf59e02c75c61e5be74711fc1d4918224a8953cff766f80a66c0f8e
+ sha256sums = aac1c0aac453470bbfd1f65033a1fdaeb6eb660ba15e94cc10262c054bb9aa23
+ sha256sums = afe2ca6ed0cec06256d329a1529e5d299eb289cb25132ef253d6d2e9b7489aa8
pkgname = foxitreader
diff --git a/PKGBUILD b/PKGBUILD
index 296b476f4c4..494fcc1b124 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,30 @@
pkgname=foxitreader
pkgver=2.4.1.0609
-_frrev_i686=r08f07f8
-_frrev_x86_64=${_frrev_i686}
-pkgrel=4
+_foxitrevision=r08f07f8
+pkgrel=5
pkgdesc="A fast, secure and complete PDF viewer"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.foxitsoftware.com/products/pdf-reader/"
license=('custom:EULA')
-makedepends=('qt-installer-framework>=3.0.1' 'qt5-tools' 'p7zip')
depends=('libsecret' 'qt5-webkit')
-source=("https://www.foxitsoftware.com/products/pdf-reader/eula.html"
- "${pkgname}.patch")
-source_i686=("http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/${pkgver%.*.*}/en_us/FoxitReader${pkgver}_Server_x86_enu_Setup.run.tar.gz"
- "${pkgname}-excluded_files-i686")
-source_x86_64=("http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/${pkgver%.*.*}/en_us/FoxitReader${pkgver}_Server_x64_enu_Setup.run.tar.gz"
- "${pkgname}-excluded_files-x86_64")
-sha256sums=('c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079'
- 'd85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1')
-sha256sums_i686=('03dd1c4d248bd1782a9a9dd46836ffec9f38128b5f34ad3370a71d33fd87c9bc'
- '58addc465b629286552a9166ab70509c2f87bee9f7519dcd567a183f5dcaba9b')
-sha256sums_x86_64=('d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba'
- '02d9bb529bf59e02c75c61e5be74711fc1d4918224a8953cff766f80a66c0f8e')
+source=("http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/${pkgver%.*.*}/en_us/FoxitReader${pkgver}_Server_x64_enu_Setup.run.tar.gz"
+ "https://www.foxitsoftware.com/products/pdf-reader/eula.html"
+ "${pkgname}.patch"
+ "${pkgname}-excluded_files-x86_64"
+ "installer.qs")
+sha256sums=('d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba'
+ 'c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079'
+ 'd85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1'
+ 'aac1c0aac453470bbfd1f65033a1fdaeb6eb660ba15e94cc10262c054bb9aa23'
+ 'afe2ca6ed0cec06256d329a1529e5d299eb289cb25132ef253d6d2e9b7489aa8')
+
+prepare() {
+ # Fix output path in the installer script
+ sed "s#OUTPUT_DIRECTORY#${srcdir}/${pkgname}-installer#" "${srcdir}/installer.qs" > "${pkgname}.qs"
+}
build() {
- local _file
local _line
# Clean installer dir
if [ -d "${pkgname}-installer" ]
@@ -35,33 +35,17 @@ build() {
rm -rf "${pkgname}-installer"
fi
# Decompress .run installer
- if [ "${CARCH}" = 'x86_64' ]
- then
- _file="FoxitReader.enu.setup.${pkgver}(${_frrev_x86_64}).x64.run"
- else
- _file="FoxitReader.enu.setup.${pkgver}(${_frrev_i686}).x86.run"
- fi
- devtool dump "${_file}" "${pkgname}-installer"
- # Clean build dir
- if [ -d "${pkgname}-build" ]
- then
- rm -rf "${pkgname}-build"
- fi
- # Decompress files
- cd "${pkgname}-installer/metadata/Install Foxit Reader"
- install -m 755 -d "${srcdir}/${pkgname}-build"
- for _file in *.7z
- do
- 7z x -o"${srcdir}/${pkgname}-build" ${_file} > /dev/null
- done
+ QT_QPA_PLATFORM=minimal "./FoxitReader.enu.setup.${pkgver}(${_foxitrevision}).x64.run" \
+ --script "${pkgname}.qs" "${srcdir}/${pkgname}-installer"
# Apply final patches
- cd "${srcdir}/${pkgname}-build"
- patch -p4 -i "${srcdir}/${pkgname}.patch"
+ cd "${srcdir}/${pkgname}-installer"
+ patch -p4 --no-backup-if-mismatch -i "${srcdir}/${pkgname}.patch"
# Remove unneeded files
rm "Activation" "Activation.desktop" "Activation.sh" \
"countinstalltion" "countinstalltion.sh" \
- "installUpdate" "ldlibrarypath.sh" \
- "maintenancetool.sh" "Uninstall.desktop" \
+ "installUpdate" \
+ "maintenancetool" "maintenancetool.dat" "maintenancetool.ini" "maintenancetool.sh" \
+ "Uninstall.desktop" \
"Update.desktop" "updater" "updater.sh"
find -type d -name ".svn" -exec rm -rf {} +
find -type f -name ".directory" -exec rm -rf {} +
@@ -69,12 +53,12 @@ build() {
# Remove excluded files
while IFS='' read -r _line
do
- if [ "${_line::1}" == '#' ]
+ if [ "${_line::2}" = "# " ]
then
echo " -> Removing excluded files from ${_line:2}..."
- elif [ -n "${_line}" ]
+ elif [ -n "${_line}" -a "${_line::1}" != "#" ]
then
- rm "${srcdir}/${pkgname}-build/${_line}"
+ rm "${srcdir}/${pkgname}-installer/${_line}"
fi
done < "${srcdir}/${pkgname}-excluded_files-$CARCH"
}
@@ -83,7 +67,7 @@ check() {
# Check for unwanted libraries
local _file
local _unwanted=0
- cd "${srcdir}/${pkgname}-build/lib"
+ cd "${srcdir}/${pkgname}-installer/lib"
# Check if lib folders is not empty
if [ "$(ls -A .)" ]
@@ -111,7 +95,7 @@ check() {
package() {
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
- cd "${srcdir}/${pkgname}-build"
+ cd "${srcdir}/${pkgname}-installer"
cp -r * "${pkgdir}/usr/lib/${pkgname}"
# Install icon and desktop files
install -m 755 -d "${pkgdir}/usr/share/pixmaps"
diff --git a/foxitreader-excluded_files-i686 b/foxitreader-excluded_files-i686
deleted file mode 100644
index e0f5bbc4f4d..00000000000
--- a/foxitreader-excluded_files-i686
+++ /dev/null
@@ -1,102 +0,0 @@
-# gstreamer0.10-base
-lib/libgstapp-0.10.so.0
-lib/libgstapp-0.10.so.0.25.0
-lib/libgstbase-0.10.so.0
-lib/libgstbase-0.10.so.0.30.0
-lib/libgstinterfaces-0.10.so.0
-lib/libgstinterfaces-0.10.so.0.25.0
-lib/libgstpbutils-0.10.so.0
-lib/libgstpbutils-0.10.so.0.25.0
-lib/libgstvideo-0.10.so.0
-lib/libgstvideo-0.10.so.0.25.0
-
-# gstreamer0.10
-lib/libgstreamer-0.10.so.0
-lib/libgstreamer-0.10.so.0.30.0
-
-# libgcrypt
-lib/libgcrypt.so.20
-lib/libgcrypt.so.20.0
-lib/libgcrypt.so.20.0.1
-
-# openssl
-lib/libcrypto.so.1
-lib/libcrypto.so.1.0
-lib/libcrypto.so.1.0.0
-lib/libssl.so.1
-lib/libssl.so.1.0
-lib/libssl.so.1.0.0
-
-# fcitx-qt5
-lib/libFcitxQt5DBusAddons.so
-lib/libFcitxQt5DBusAddons.so.1
-lib/libFcitxQt5DBusAddons.so.1.0
-lib/libFcitxQt5WidgetsAddons.so
-lib/libFcitxQt5WidgetsAddons.so.1
-lib/libFcitxQt5WidgetsAddons.so.1.0
-
-# icu
-lib/libicudata.so.52
-lib/libicui18n.so.52
-lib/libicui18n.so.52.1
-lib/libicuuc.so.52
-lib/libicuuc.so.52.1
-
-# libsecret
-lib/libsecret-1.so
-lib/libsecret-1.so.0
-lib/libsecret-1.so.0.0.0
-
-# libxkbcommon
-lib/libxkbcommon.so
-lib/libxkbcommon.so.0
-lib/libxkbcommon.so.0.0
-lib/libxkbcommon.so.0.0.0
-
-# qt5-base
-lib/libQt5Core.so.5
-lib/libQt5Core.so.5.3.2
-lib/libQt5DBus.so.5
-lib/libQt5DBus.so.5.3.2
-lib/libQt5Gui.so.5
-lib/libQt5Gui.so.5.3.2
-lib/libQt5Network.so.5
-lib/libQt5Network.so.5.3.2
-lib/libQt5OpenGL.so.5
-lib/libQt5OpenGL.so.5.3.2
-lib/libQt5Sql.so.5
-lib/libQt5Sql.so.5.3.2
-lib/libQt5Widgets.so.5
-lib/libQt5Widgets.so.5.3.2
-lib/libQt5Xml.so.5
-lib/libQt5Xml.so.5.3.2
-## libQt5PrintSupport actually crashes with foxitreader during print, leaving it
-lib/libQt5PrintSupport.so.5
-#lib/libQt5PrintSupport.so.5.3.2
-
-# qt5-location
-lib/libQt5Positioning.so.5
-lib/libQt5Positioning.so.5.3.2
-
-# qt5-declarative
-lib/libQt5Qml.so.5
-lib/libQt5Qml.so.5.3.2
-lib/libQt5Quick.so.5
-lib/libQt5Quick.so.5.3.2
-lib/libQt5QuickWidgets.so.5
-lib/libQt5QuickWidgets.so.5.3.2
-
-# qt5-sensors
-lib/libQt5Sensors.so.5
-lib/libQt5Sensors.so.5.3.2
-
-# qt5-webkit
-lib/libQt5WebKit.so.5
-lib/libQt5WebKit.so.5.3.2
-lib/libQt5WebKitWidgets.so.5
-lib/libQt5WebKitWidgets.so.5.3.2
-
-# qt5-xmlpatterns
-lib/libQt5XmlPatterns.so.5
-lib/libQt5XmlPatterns.so.5.3.2
-
diff --git a/foxitreader-excluded_files-x86_64 b/foxitreader-excluded_files-x86_64
index 711f15181d6..bd6d415fa80 100644
--- a/foxitreader-excluded_files-x86_64
+++ b/foxitreader-excluded_files-x86_64
@@ -1,11 +1,3 @@
-# gcc-libs
-lib/libstdc++.so.6
-
-# glib2
-lib/libglib-2.0.so.0
-lib/libgobject-2.0.so.0
-lib/libgthread-2.0.so.0
-
# gstreamer0.10-base
lib/libgstapp-0.10.so.0
lib/libgstapp-0.10.so.0.25.0
@@ -89,7 +81,7 @@ lib/libQt5Xml.so
lib/libQt5Xml.so.5
lib/libQt5Xml.so.5.3
lib/libQt5Xml.so.5.3.2
-# libQt5PrintSupport actually crashes with foxitreader during print, leaving it
+#libQt5PrintSupport actually crashes with foxitreader during print, leaving it
#lib/libQt5PrintSupport.so
#lib/libQt5PrintSupport.so.5
#lib/libQt5PrintSupport.so.5.3
diff --git a/installer.qs b/installer.qs
new file mode 100644
index 00000000000..b742f164fbc
--- /dev/null
+++ b/installer.qs
@@ -0,0 +1,45 @@
+function log() {
+ var msg = ["INSTALLER: "].concat([].slice.call(arguments));
+ console.log(msg.join(" "));
+}
+
+function Controller() {
+}
+
+Controller.prototype.WelcomePageCallback = function() {
+ log("WelcomePageCallback");
+ gui.clickButton(buttons.NextButton);
+}
+
+Controller.prototype.IntroductionPageCallback = function() {
+ log("IntroductionPageCallback");
+ gui.clickButton(buttons.NextButton);
+}
+
+Controller.prototype.DynamicTargetWidgetCallback = function() {
+ log("DynamicTargetWidgetCallback");
+ var widget = gui.pageWidgetByObjectName("DynamicTargetWidget");
+
+ if (widget != null) {
+ widget.targetDirectory.setText("OUTPUT_DIRECTORY");
+ }
+ gui.clickButton(buttons.NextButton);
+}
+
+Controller.prototype.DynamicLicenseWidgetCallback = function() {
+ log("DynamicLicenseWidgetCallback");
+ var widget = gui.pageWidgetByObjectName("DynamicLicenseWidget");
+
+ if (widget != null) {
+ widget.acceptLicense.checked = true;
+ }
+
+ gui.clickButton(buttons.NextButton);
+
+}
+
+Controller.prototype.FinishedPageCallback = function() {
+ log("FinishedPageCallback");
+ gui.clickButton(buttons.FinishButton);
+}
+