summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-02-04 14:34:25 +0100
committerMuflone2018-02-04 14:34:25 +0100
commit877d11c2e0a501bb0bf5eeaeb01e4e104082dffa (patch)
tree512257d1d375a259a3bd7dba191d8b262a7e5c36
parent0c11b775e7696728cb001e18f56546488acb89ed (diff)
downloadaur-877d11c2e0a501bb0bf5eeaeb01e4e104082dffa.tar.gz
Updated package foxitreader 2.4.1.0609-9
Added missing dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
-rw-r--r--foxitreader-excluded_files49
-rw-r--r--foxitreader-excluded_files-x86_64138
4 files changed, 63 insertions, 147 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ccd8675a02..20de8eec155 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,27 @@
# Generated by mksrcinfo v8
-# Sat Feb 3 22:54:48 UTC 2018
+# Sun Feb 4 13:33:08 UTC 2018
pkgbase = foxitreader
pkgdesc = A fast, secure and complete PDF viewer
pkgver = 2.4.1.0609
- pkgrel = 8
+ pkgrel = 9
url = https://www.foxitsoftware.com/products/pdf-reader/
arch = x86_64
license = custom:EULA
makedepends = p7zip
depends = libsecret
+ depends = libxslt
+ depends = libxcomposite
+ depends = libgl
+ depends = libxrender
+ depends = gstreamer0.10-base
source = http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz
source = https://www.foxitsoftware.com/products/pdf-reader/eula.html
source = foxitreader.patch
- source = foxitreader-excluded_files-x86_64
+ source = foxitreader-excluded_files
sha256sums = d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba
sha256sums = c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079
sha256sums = d85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1
- sha256sums = 87932852ae1ce12bc8e9e7a7d3cdf2f8fdcdf8cf5f27871f1297b920223c4aa7
+ sha256sums = e558529c6dbea047eee744b011ffcc214547c503896b14211ebf5f6309ef4e9f
pkgname = foxitreader
diff --git a/PKGBUILD b/PKGBUILD
index 4bc7d3d96d1..370277fa4c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,21 @@
pkgname=foxitreader
pkgver=2.4.1.0609
_foxitrevision=r08f07f8
-pkgrel=8
+pkgrel=9
pkgdesc="A fast, secure and complete PDF viewer"
arch=('x86_64')
url="https://www.foxitsoftware.com/products/pdf-reader/"
license=('custom:EULA')
-depends=('libsecret')
+depends=('libsecret' 'libxslt' 'libxcomposite' 'libgl' 'libxrender' 'gstreamer0.10-base')
makedepends=('p7zip')
source=("http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/${pkgver%.*.*}/en_us/FoxitReader${pkgver}_Server_x64_enu_Setup.run.tar.gz"
"https://www.foxitsoftware.com/products/pdf-reader/eula.html"
"${pkgname}.patch"
- "${pkgname}-excluded_files-x86_64")
+ "${pkgname}-excluded_files")
sha256sums=('d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba'
'c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079'
'd85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1'
- '87932852ae1ce12bc8e9e7a7d3cdf2f8fdcdf8cf5f27871f1297b920223c4aa7')
+ 'e558529c6dbea047eee744b011ffcc214547c503896b14211ebf5f6309ef4e9f')
build() {
local _file
@@ -75,7 +75,7 @@ build() {
then
rm "${srcdir}/${pkgname}-build/${_line}"
fi
- done < "${srcdir}/${pkgname}-excluded_files-$CARCH"
+ done < "${srcdir}/${pkgname}-excluded_files"
}
package() {
diff --git a/foxitreader-excluded_files b/foxitreader-excluded_files
new file mode 100644
index 00000000000..2abb2edbbac
--- /dev/null
+++ b/foxitreader-excluded_files
@@ -0,0 +1,49 @@
+# glib2
+lib/libglib-2.0.so.0
+lib/libgobject-2.0.so.0
+lib/libgthread-2.0.so.0
+
+# gcc-libs
+lib/libstdc++.so.6
+
+# gstreamer0.10-base
+lib/libgstapp-0.10.so.0
+lib/libgstapp-0.10.so.0.25.0
+lib/libgstbase-0.10.so.0
+lib/libgstinterfaces-0.10.so.0
+lib/libgstinterfaces-0.10.so.0.25.0
+lib/libgstpbutils-0.10.so.0
+lib/libgstpbutils-0.10.so.0.25.0
+lib/libgstvideo-0.10.so.0
+
+# gst-plugins-base-libs
+lib/libgstpbutils-1.0.so.0
+lib/libgstpbutils-1.0.so.0.403.0
+
+# gstreamer0.10
+lib/libgstreamer-0.10.so.0
+lib/libgstreamer-0.10.so.0.30.0
+
+# libgcrypt
+lib/libgcrypt.so.11
+
+# openssl
+lib/libcrypto.so.10
+lib/libssl.so.10
+
+# libffi
+lib/libffi.so.5
+
+# libsecret
+lib/libsecret-1.so
+lib/libsecret-1.so.0
+
+# libxkbcommon
+lib/libxkbcommon.so.0
+lib/libxkbcommon.so.0.0.0
+
+# libxslt
+lib/libxslt.so.1
+lib/libxslt.so.1.1
+lib/libxslt.so.1.1.26
+
diff --git a/foxitreader-excluded_files-x86_64 b/foxitreader-excluded_files-x86_64
deleted file mode 100644
index cfeb99425e1..00000000000
--- a/foxitreader-excluded_files-x86_64
+++ /dev/null
@@ -1,138 +0,0 @@
-# glib2
-lib/libglib-2.0.so.0
-lib/libgobject-2.0.so.0
-lib/libgthread-2.0.so.0
-
-# gcc-libs
-lib/libstdc++.so.6
-
-# gstreamer0.10-base
-lib/libgstapp-0.10.so.0
-lib/libgstapp-0.10.so.0.25.0
-lib/libgstbase-0.10.so.0
-lib/libgstinterfaces-0.10.so.0
-lib/libgstinterfaces-0.10.so.0.25.0
-lib/libgstpbutils-0.10.so.0
-lib/libgstpbutils-0.10.so.0.25.0
-lib/libgstvideo-0.10.so.0
-
-# gst-plugins-base-libs
-lib/libgstpbutils-1.0.so.0
-lib/libgstpbutils-1.0.so.0.403.0
-
-# gstreamer0.10
-lib/libgstreamer-0.10.so.0
-lib/libgstreamer-0.10.so.0.30.0
-
-# libgcrypt
-lib/libgcrypt.so.11
-
-# openssl
-lib/libcrypto.so.10
-lib/libssl.so.10
-
-# libffi
-lib/libffi.so.5
-
-# fcitx-qt5
-lib/libFcitxQt5DBusAddons.so.1
-lib/libFcitxQt5DBusAddons.so.1.0
-
-# icu
-#lib/libicudata.so.52
-#lib/libicui18n.so.52
-#lib/libicui18n.so.52.1
-#lib/libicuuc.so.52
-#lib/libicuuc.so.52.1
-
-# libsecret
-lib/libsecret-1.so
-lib/libsecret-1.so.0
-
-# libxkbcommon
-lib/libxkbcommon.so.0
-lib/libxkbcommon.so.0.0.0
-
-# libxslt
-lib/libxslt.so.1
-lib/libxslt.so.1.1
-lib/libxslt.so.1.1.26
-
-# qt5-base
-#lib/libQt5Core.so
-#lib/libQt5Core.so.5
-#lib/libQt5Core.so.5.3
-#lib/libQt5Core.so.5.3.2
-#lib/libQt5DBus.so
-#lib/libQt5DBus.so.5
-#lib/libQt5DBus.so.5.3
-#lib/libQt5DBus.so.5.3.2
-#lib/libQt5Gui.so
-#lib/libQt5Gui.so.5
-#lib/libQt5Gui.so.5.3
-#lib/libQt5Gui.so.5.3.2
-#lib/libQt5Network.so
-#lib/libQt5Network.so.5
-#lib/libQt5Network.so.5.3
-#lib/libQt5Network.so.5.3.2
-#lib/libQt5OpenGL.so
-#lib/libQt5OpenGL.so.5
-#lib/libQt5OpenGL.so.5.3
-#lib/libQt5OpenGL.so.5.3.2
-#lib/libQt5Sql.so
-#lib/libQt5Sql.so.5
-#lib/libQt5Sql.so.5.3
-#lib/libQt5Sql.so.5.3.2
-#lib/libQt5Widgets.so.5
-#lib/libQt5Widgets.so.5.3.2
-#lib/libQt5Xml.so
-#lib/libQt5Xml.so.5
-#lib/libQt5Xml.so.5.3
-#lib/libQt5Xml.so.5.3.2
-#lib/libQt5PrintSupport.so
-#lib/libQt5PrintSupport.so.5
-#lib/libQt5PrintSupport.so.5.3
-#lib/libQt5PrintSupport.so.5.3.2
-
-# qt5-location
-#lib/libQt5Positioning.so
-#lib/libQt5Positioning.so.5
-#lib/libQt5Positioning.so.5.3
-#lib/libQt5Positioning.so.5.3.2
-
-# qt5-declarative
-#lib/libQt5Qml.so
-#lib/libQt5Qml.so.5
-#lib/libQt5Qml.so.5.3
-#lib/libQt5Qml.so.5.3.2
-#lib/libQt5Quick.so
-#lib/libQt5Quick.so.5
-#lib/libQt5Quick.so.5.3
-#lib/libQt5Quick.so.5.3.2
-#lib/libQt5QuickWidgets.so
-#lib/libQt5QuickWidgets.so.5
-#lib/libQt5QuickWidgets.so.5.3
-#lib/libQt5QuickWidgets.so.5.3.2
-
-# qt5-sensors
-#lib/libQt5Sensors.so
-#lib/libQt5Sensors.so.5
-#lib/libQt5Sensors.so.5.3
-#lib/libQt5Sensors.so.5.3.2
-
-# qt5-webkit
-#lib/libQt5WebKit.so
-#lib/libQt5WebKit.so.5
-#lib/libQt5WebKit.so.5.3
-#lib/libQt5WebKit.so.5.3.2
-#lib/libQt5WebKitWidgets.so
-#lib/libQt5WebKitWidgets.so.5
-#lib/libQt5WebKitWidgets.so.5.3
-#lib/libQt5WebKitWidgets.so.5.3.2
-
-# qt5-xmlpatterns
-lib/libQt5XmlPatterns.so
-lib/libQt5XmlPatterns.so.5
-lib/libQt5XmlPatterns.so.5.3
-lib/libQt5XmlPatterns.so.5.3.2
-