summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-02-03 23:50:12 +0100
committerMuflone2018-02-03 23:50:12 +0100
commit93a6c33abf091f898dbb6f928c0a346ef56909cc (patch)
tree9d49c620902838cb0f13876f45ecb42ec0196a31
parent7ed51d8a0c21d35918551ca142f6bdd3bd899a95 (diff)
downloadaur-93a6c33abf091f898dbb6f928c0a346ef56909cc.tar.gz
Updated package foxitreader 2.4.1.0609-7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD83
-rw-r--r--foxitreader-excluded_files-x86_64135
-rw-r--r--installer.qs45
4 files changed, 108 insertions, 164 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 022fb2f75e68..48e6d47611ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Jan 14 19:34:49 UTC 2018
+# Sat Feb 3 22:49:03 UTC 2018
pkgbase = foxitreader
pkgdesc = A fast, secure and complete PDF viewer
pkgver = 2.4.1.0609
- pkgrel = 6
+ pkgrel = 7
url = https://www.foxitsoftware.com/products/pdf-reader/
arch = x86_64
license = custom:EULA
+ makedepends = p7zip
depends = libsecret
depends = qt5-webkit
source = http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/2.4/en_us/FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz
source = https://www.foxitsoftware.com/products/pdf-reader/eula.html
source = foxitreader.patch
source = foxitreader-excluded_files-x86_64
- source = installer.qs
sha256sums = d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba
sha256sums = c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079
sha256sums = d85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1
- sha256sums = aac1c0aac453470bbfd1f65033a1fdaeb6eb660ba15e94cc10262c054bb9aa23
- sha256sums = afe2ca6ed0cec06256d329a1529e5d299eb289cb25132ef253d6d2e9b7489aa8
+ sha256sums = 87932852ae1ce12bc8e9e7a7d3cdf2f8fdcdf8cf5f27871f1297b920223c4aa7
pkgname = foxitreader
diff --git a/PKGBUILD b/PKGBUILD
index 5a7672b41838..b55388edc836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,49 +5,62 @@
pkgname=foxitreader
pkgver=2.4.1.0609
_foxitrevision=r08f07f8
-pkgrel=6
+pkgrel=7
pkgdesc="A fast, secure and complete PDF viewer"
arch=('x86_64')
url="https://www.foxitsoftware.com/products/pdf-reader/"
license=('custom:EULA')
depends=('libsecret' 'qt5-webkit')
+makedepends=('p7zip')
source=("http://cdn09.foxitsoftware.com/pub/foxit/reader/desktop/linux/2.x/${pkgver%.*.*}/en_us/FoxitReader${pkgver}_Server_x64_enu_Setup.run.tar.gz"
"https://www.foxitsoftware.com/products/pdf-reader/eula.html"
"${pkgname}.patch"
- "${pkgname}-excluded_files-x86_64"
- "installer.qs")
+ "${pkgname}-excluded_files-x86_64")
sha256sums=('d8093dd3b3aeb4e788cbdff5f9d05d7557eb440810f6da6bdc4e23447d3a27ba'
'c1485614de2b8087d14ab2d7b10e51faaaaf83a96f8bce6a0e1791effadf6079'
'd85bfa4b293927975182aa6b1582ac064c5732711e5678d5f1ec35e65c78e6d1'
- 'aac1c0aac453470bbfd1f65033a1fdaeb6eb660ba15e94cc10262c054bb9aa23'
- 'afe2ca6ed0cec06256d329a1529e5d299eb289cb25132ef253d6d2e9b7489aa8')
-
-prepare() {
- # Fix output path in the installer script
- sed "s#OUTPUT_DIRECTORY#${srcdir}/${pkgname}-installer#" "${srcdir}/installer.qs" > "${pkgname}.qs"
-}
+ '87932852ae1ce12bc8e9e7a7d3cdf2f8fdcdf8cf5f27871f1297b920223c4aa7')
build() {
+ local _file
local _line
+ local _position
# Clean installer dir
if [ -d "${pkgname}-installer" ]
then
rm -rf "${pkgname}-installer"
fi
+ mkdir "${pkgname}-installer"
# Decompress .run installer
- QT_QPA_PLATFORM=minimal "./FoxitReader.enu.setup.${pkgver}(${_foxitrevision}).x64.run" \
- --script "${pkgname}.qs" "${srcdir}/${pkgname}-installer"
- # Fix desktop file path
- cd "${srcdir}/${pkgname}-installer"
- sed -i '/Exec=/d' FoxitReader.desktop
+ _file="FoxitReader.enu.setup.${pkgver}(${_foxitrevision}).x64.run"
+ LANG=C grep --only-matching --byte-offset --binary \
+ --text $'7z\xBC\xAF\x27\x1C' "${_file}" | cut -f1 -d: |
+ while read _position
+ do
+ dd if="${_file}" \
+ bs=1M iflag=skip_bytes status=none skip=${_position} \
+ of="${pkgname}-installer/bin-${_position}.7z"
+ done
+ # Clean build dir
+ if [ -d "${pkgname}-build" ]
+ then
+ rm -rf "${pkgname}-build"
+ fi
+ # Decompress 7z files (some files are damaged during the extraction)
+ cd "${pkgname}-installer"
+ install -m 755 -d "${srcdir}/${pkgname}-build"
+ for _file in *.7z
+ do
+ 7z -bd -bb0 -y x -o"${srcdir}/${pkgname}-build" ${_file} 1>/dev/null 2>&1 || true
+ done
# Apply final patches
+ cd "${srcdir}/${pkgname}-build"
patch -p4 --no-backup-if-mismatch -i "${srcdir}/${pkgname}.patch"
# Remove unneeded files
rm "Activation" "Activation.desktop" "Activation.sh" \
"countinstalltion" "countinstalltion.sh" \
- "installUpdate" \
- "maintenancetool" "maintenancetool.dat" "maintenancetool.ini" "maintenancetool.sh" \
- "Uninstall.desktop" \
+ "installUpdate" "ldlibrarypath.sh" \
+ "maintenancetool.sh" "Uninstall.desktop" \
"Update.desktop" "updater" "updater.sh"
find -type d -name ".svn" -exec rm -rf {} +
find -type f -name ".directory" -exec rm -rf {} +
@@ -60,44 +73,14 @@ build() {
echo " -> Removing excluded files from ${_line:2}..."
elif [ -n "${_line}" -a "${_line::1}" != "#" ]
then
- rm "${srcdir}/${pkgname}-installer/${_line}"
+ rm "${srcdir}/${pkgname}-build/${_line}"
fi
done < "${srcdir}/${pkgname}-excluded_files-$CARCH"
}
-check() {
- # Check for unwanted libraries
- local _file
- local _unwanted=0
- cd "${srcdir}/${pkgname}-installer/lib"
-
- # Check if lib folders is not empty
- if [ "$(ls -A .)" ]
- then
- ls -l
- # Check every library file
- for _file in *
- do
- if [ "${_file}" != 'libQt5PrintSupport.so' -a \
- "${_file}" != 'libQt5PrintSupport.so.5' -a \
- "${_file}" != 'libQt5PrintSupport.so.5.3' -a \
- "${_file}" != 'libQt5PrintSupport.so.5.3.2' ]
- then
- echo " -> Unwanted library ${_file}"
- _unwanted=1
- fi
- done
- if [ ${_unwanted} -ne 0 ]
- then
- echo " -> At least an unwanted library exists in $PWD"
- exit 1
- fi
- fi
-}
-
package() {
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
- cd "${srcdir}/${pkgname}-installer"
+ cd "${srcdir}/${pkgname}-build"
cp -r * "${pkgdir}/usr/lib/${pkgname}"
# Install icon and desktop files
install -m 755 -d "${pkgdir}/usr/share/pixmaps"
diff --git a/foxitreader-excluded_files-x86_64 b/foxitreader-excluded_files-x86_64
index bd6d415fa807..cfeb99425e16 100644
--- a/foxitreader-excluded_files-x86_64
+++ b/foxitreader-excluded_files-x86_64
@@ -1,3 +1,11 @@
+# glib2
+lib/libglib-2.0.so.0
+lib/libgobject-2.0.so.0
+lib/libgthread-2.0.so.0
+
+# gcc-libs
+lib/libstdc++.so.6
+
# gstreamer0.10-base
lib/libgstapp-0.10.so.0
lib/libgstapp-0.10.so.0.25.0
@@ -31,11 +39,11 @@ lib/libFcitxQt5DBusAddons.so.1
lib/libFcitxQt5DBusAddons.so.1.0
# icu
-lib/libicudata.so.52
-lib/libicui18n.so.52
-lib/libicui18n.so.52.1
-lib/libicuuc.so.52
-lib/libicuuc.so.52.1
+#lib/libicudata.so.52
+#lib/libicui18n.so.52
+#lib/libicui18n.so.52.1
+#lib/libicuuc.so.52
+#lib/libicuuc.so.52.1
# libsecret
lib/libsecret-1.so
@@ -51,77 +59,76 @@ lib/libxslt.so.1.1
lib/libxslt.so.1.1.26
# qt5-base
-lib/libQt5Core.so
-lib/libQt5Core.so.5
-lib/libQt5Core.so.5.3
-lib/libQt5Core.so.5.3.2
-lib/libQt5DBus.so
-lib/libQt5DBus.so.5
-lib/libQt5DBus.so.5.3
-lib/libQt5DBus.so.5.3.2
-lib/libQt5Gui.so
-lib/libQt5Gui.so.5
-lib/libQt5Gui.so.5.3
-lib/libQt5Gui.so.5.3.2
-lib/libQt5Network.so
-lib/libQt5Network.so.5
-lib/libQt5Network.so.5.3
-lib/libQt5Network.so.5.3.2
-lib/libQt5OpenGL.so
-lib/libQt5OpenGL.so.5
-lib/libQt5OpenGL.so.5.3
-lib/libQt5OpenGL.so.5.3.2
-lib/libQt5Sql.so
-lib/libQt5Sql.so.5
-lib/libQt5Sql.so.5.3
-lib/libQt5Sql.so.5.3.2
-lib/libQt5Widgets.so.5
-lib/libQt5Widgets.so.5.3.2
-lib/libQt5Xml.so
-lib/libQt5Xml.so.5
-lib/libQt5Xml.so.5.3
-lib/libQt5Xml.so.5.3.2
-#libQt5PrintSupport actually crashes with foxitreader during print, leaving it
+#lib/libQt5Core.so
+#lib/libQt5Core.so.5
+#lib/libQt5Core.so.5.3
+#lib/libQt5Core.so.5.3.2
+#lib/libQt5DBus.so
+#lib/libQt5DBus.so.5
+#lib/libQt5DBus.so.5.3
+#lib/libQt5DBus.so.5.3.2
+#lib/libQt5Gui.so
+#lib/libQt5Gui.so.5
+#lib/libQt5Gui.so.5.3
+#lib/libQt5Gui.so.5.3.2
+#lib/libQt5Network.so
+#lib/libQt5Network.so.5
+#lib/libQt5Network.so.5.3
+#lib/libQt5Network.so.5.3.2
+#lib/libQt5OpenGL.so
+#lib/libQt5OpenGL.so.5
+#lib/libQt5OpenGL.so.5.3
+#lib/libQt5OpenGL.so.5.3.2
+#lib/libQt5Sql.so
+#lib/libQt5Sql.so.5
+#lib/libQt5Sql.so.5.3
+#lib/libQt5Sql.so.5.3.2
+#lib/libQt5Widgets.so.5
+#lib/libQt5Widgets.so.5.3.2
+#lib/libQt5Xml.so
+#lib/libQt5Xml.so.5
+#lib/libQt5Xml.so.5.3
+#lib/libQt5Xml.so.5.3.2
#lib/libQt5PrintSupport.so
#lib/libQt5PrintSupport.so.5
#lib/libQt5PrintSupport.so.5.3
#lib/libQt5PrintSupport.so.5.3.2
# qt5-location
-lib/libQt5Positioning.so
-lib/libQt5Positioning.so.5
-lib/libQt5Positioning.so.5.3
-lib/libQt5Positioning.so.5.3.2
+#lib/libQt5Positioning.so
+#lib/libQt5Positioning.so.5
+#lib/libQt5Positioning.so.5.3
+#lib/libQt5Positioning.so.5.3.2
# qt5-declarative
-lib/libQt5Qml.so
-lib/libQt5Qml.so.5
-lib/libQt5Qml.so.5.3
-lib/libQt5Qml.so.5.3.2
-lib/libQt5Quick.so
-lib/libQt5Quick.so.5
-lib/libQt5Quick.so.5.3
-lib/libQt5Quick.so.5.3.2
-lib/libQt5QuickWidgets.so
-lib/libQt5QuickWidgets.so.5
-lib/libQt5QuickWidgets.so.5.3
-lib/libQt5QuickWidgets.so.5.3.2
+#lib/libQt5Qml.so
+#lib/libQt5Qml.so.5
+#lib/libQt5Qml.so.5.3
+#lib/libQt5Qml.so.5.3.2
+#lib/libQt5Quick.so
+#lib/libQt5Quick.so.5
+#lib/libQt5Quick.so.5.3
+#lib/libQt5Quick.so.5.3.2
+#lib/libQt5QuickWidgets.so
+#lib/libQt5QuickWidgets.so.5
+#lib/libQt5QuickWidgets.so.5.3
+#lib/libQt5QuickWidgets.so.5.3.2
# qt5-sensors
-lib/libQt5Sensors.so
-lib/libQt5Sensors.so.5
-lib/libQt5Sensors.so.5.3
-lib/libQt5Sensors.so.5.3.2
+#lib/libQt5Sensors.so
+#lib/libQt5Sensors.so.5
+#lib/libQt5Sensors.so.5.3
+#lib/libQt5Sensors.so.5.3.2
# qt5-webkit
-lib/libQt5WebKit.so
-lib/libQt5WebKit.so.5
-lib/libQt5WebKit.so.5.3
-lib/libQt5WebKit.so.5.3.2
-lib/libQt5WebKitWidgets.so
-lib/libQt5WebKitWidgets.so.5
-lib/libQt5WebKitWidgets.so.5.3
-lib/libQt5WebKitWidgets.so.5.3.2
+#lib/libQt5WebKit.so
+#lib/libQt5WebKit.so.5
+#lib/libQt5WebKit.so.5.3
+#lib/libQt5WebKit.so.5.3.2
+#lib/libQt5WebKitWidgets.so
+#lib/libQt5WebKitWidgets.so.5
+#lib/libQt5WebKitWidgets.so.5.3
+#lib/libQt5WebKitWidgets.so.5.3.2
# qt5-xmlpatterns
lib/libQt5XmlPatterns.so
diff --git a/installer.qs b/installer.qs
deleted file mode 100644
index b742f164fbcf..000000000000
--- a/installer.qs
+++ /dev/null
@@ -1,45 +0,0 @@
-function log() {
- var msg = ["INSTALLER: "].concat([].slice.call(arguments));
- console.log(msg.join(" "));
-}
-
-function Controller() {
-}
-
-Controller.prototype.WelcomePageCallback = function() {
- log("WelcomePageCallback");
- gui.clickButton(buttons.NextButton);
-}
-
-Controller.prototype.IntroductionPageCallback = function() {
- log("IntroductionPageCallback");
- gui.clickButton(buttons.NextButton);
-}
-
-Controller.prototype.DynamicTargetWidgetCallback = function() {
- log("DynamicTargetWidgetCallback");
- var widget = gui.pageWidgetByObjectName("DynamicTargetWidget");
-
- if (widget != null) {
- widget.targetDirectory.setText("OUTPUT_DIRECTORY");
- }
- gui.clickButton(buttons.NextButton);
-}
-
-Controller.prototype.DynamicLicenseWidgetCallback = function() {
- log("DynamicLicenseWidgetCallback");
- var widget = gui.pageWidgetByObjectName("DynamicLicenseWidget");
-
- if (widget != null) {
- widget.acceptLicense.checked = true;
- }
-
- gui.clickButton(buttons.NextButton);
-
-}
-
-Controller.prototype.FinishedPageCallback = function() {
- log("FinishedPageCallback");
- gui.clickButton(buttons.FinishButton);
-}
-