summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralswl2018-04-28 18:11:25 +0800
committeralswl2018-04-28 18:11:25 +0800
commit3f4d34a2ac4b2723875f70838ac9d65c4fb07845 (patch)
tree0494e633640eeb2c27f1906e9594b9da21bb5ef5
downloadaur-3f4d34a2ac4b2723875f70838ac9d65c4fb07845.tar.gz
feat: foxone
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--appimagekit-foxone-desktop.desktop14
-rw-r--r--appimagekit-foxone-desktop.pngbin0 -> 68961 bytes
-rw-r--r--foxone.sh4
6 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f2d9147247e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = foxone
+ pkgdesc = Fox.One is a trading app for cryptocurrency users, fusing together every crypto exchange in the world, help them trade smarter, faster, and with more profits and opportunities.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://www.fox.one/
+ arch = x86_64
+ license = custom
+ noextract = foxone-desktop-1.6.0-x86_64.bin
+ options = !strip
+ source = https://www.fox.one/build/foxone-desktop-1.6.0-x86_64.bin
+ source = foxone.sh
+ source = appimagekit-foxone-desktop.png
+ source = appimagekit-foxone-desktop.desktop
+ sha256sums = 96b140f71ecb488fa75535e71821c9d57db98bbdaf3019a16da80fdf0c6095d4
+ sha256sums = dec3e707f36cc4c27916f9eb92ca5c46a5690ab0887256190ed3faa07391fac1
+ sha256sums = 5c3f8bb3ace24a55bd92ea57a6cad93d2ade8e5dd5a363d6a9b114de62c28e07
+ sha256sums = f58ce4d407d296b6c521307e29ab9bdd86ba2099e4280eff2fe356d2ecb70466
+
+pkgname = foxone
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e1bfe046b71b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+*.bin
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec36c08f61b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: alswl <alswlx@gmail.com>
+
+pkgname=foxone
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Fox.One is a trading app for cryptocurrency users, fusing together every crypto exchange in the world, help them trade smarter, faster, and with more profits and opportunities."
+arch=("x86_64")
+url="https://www.fox.one/"
+license=("custom")
+depends=()
+optdepends=()
+conflicts=()
+options=(!strip)
+_desktop="appimagekit-foxone-desktop.desktop"
+source=(
+ "https://www.fox.one/build/foxone-desktop-${pkgver}-x86_64.bin"
+ "foxone.sh"
+ "appimagekit-foxone-desktop.png"
+ "${_desktop}"
+)
+noextract=("foxone-desktop-${pkgver}-x86_64.bin")
+sha256sums=(
+ "96b140f71ecb488fa75535e71821c9d57db98bbdaf3019a16da80fdf0c6095d4"
+ "dec3e707f36cc4c27916f9eb92ca5c46a5690ab0887256190ed3faa07391fac1"
+ "5c3f8bb3ace24a55bd92ea57a6cad93d2ade8e5dd5a363d6a9b114de62c28e07"
+ "f58ce4d407d296b6c521307e29ab9bdd86ba2099e4280eff2fe356d2ecb70466"
+)
+
+package() {
+ install -D -m755 "${srcdir}/foxone-desktop-${pkgver}-x86_64.bin" "${pkgdir}/opt/${pkgname}/${pkgname}"
+ install -D -m755 "${srcdir}/foxone.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
+ install -D -m644 appimagekit-foxone-desktop.png "${pkgdir}/usr/share/icons/hicolor/256x256/apps/appimagekit-foxone-desktop.png"
+}
diff --git a/appimagekit-foxone-desktop.desktop b/appimagekit-foxone-desktop.desktop
new file mode 100644
index 000000000000..9b52daf2799d
--- /dev/null
+++ b/appimagekit-foxone-desktop.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Fox
+Comment=All markets in One App
+Exec="/usr/bin/foxone" %U
+Terminal=false
+Type=Application
+Icon=appimagekit-foxone-desktop
+X-AppImage-Version=1.6.0
+X-AppImage-BuildId=05acd8a0-4a46-11a8-386f-3131eb8e1ac0
+Categories=Utility;
+X-Desktop-File-Install-Version=0.24
+X-AppImage-Comment=Generated by /tmp/.mount_foxonebQrz0I/AppRun
+TryExec=/usr/bin/foxone
+Categories=Office;Finance;
diff --git a/appimagekit-foxone-desktop.png b/appimagekit-foxone-desktop.png
new file mode 100644
index 000000000000..dfef337d4eef
--- /dev/null
+++ b/appimagekit-foxone-desktop.png
Binary files differ
diff --git a/foxone.sh b/foxone.sh
new file mode 100644
index 000000000000..4eaffde9f345
--- /dev/null
+++ b/foxone.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+export APPIMAGE_SILENT_INSTALL=true
+/opt/foxone/foxone