summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Schiffer2020-02-06 15:15:58 +0100
committerMarius Schiffer2020-02-06 15:15:58 +0100
commitd075fc76546e828a574a6d3c1ce595963f2dcb10 (patch)
tree4f0f806e54cdd1cb139f4c87cc2058c32c4d9e6f
downloadaur-d075fc76546e828a574a6d3c1ce595963f2dcb10.tar.gz
Initial PKGBUILD for 1.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34c50e289407
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fpart
+ pkgdesc = A tool that helps you sort file trees and pack them into bags, like dirsplit
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/martymac/fpart
+ arch = x86_64
+ license = custom:BSD 2-clause
+ makedepends = autoconf
+ optdepends = sh: fpsync synchronization tool
+ source = fpart-1.2.0.tar.gz::https://github.com/martymac/fpart/archive/fpart-1.2.0.tar.gz
+ sha256sums = ced59d68236d960473b5d9481f3d0c083f10a7be806c33125cc490ef2c1705f8
+
+pkgname = fpart
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75705653a2d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marius Schiffer <marius.schiffer@gmail.com>
+pkgname=fpart
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A tool that helps you sort file trees and pack them into bags, like dirsplit'
+arch=('x86_64')
+url='https://github.com/martymac/fpart'
+license=('custom:BSD 2-clause')
+depends=()
+makedepends=('autoconf')
+optdepends=('sh: fpsync synchronization tool')
+source=("fpart-${pkgver}.tar.gz::https://github.com/martymac/fpart/archive/fpart-${pkgver}.tar.gz")
+sha256sums=('ced59d68236d960473b5d9481f3d0c083f10a7be806c33125cc490ef2c1705f8')
+
+build() {
+ cd fpart-fpart-$pkgver
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd fpart-fpart-$pkgver
+ make DESTDIR="$pkgdir/" install
+ # Install license file
+ install -m644 -D COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}