summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeorize2018-04-27 21:40:43 +0700
committerLeorize2018-04-27 21:40:43 +0700
commit5ac9438256e4c5141de48690c8159f0c57aaf9c0 (patch)
tree56ffa5e8f7bdbcf3af929479887b4a35ba33b3c0
parentd6e4f4b947a6ab884db601de24cd1af388353de7 (diff)
downloadaur-fpc-svn.tar.gz
Make sure build() won't fail if docs are disabled
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4743fe85a3af..5b1905316100 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = fpc-svn
- pkgver = 3.1.1.r37950
+ pkgver = 3.1.1.r38855
pkgrel = 1
url = http://www.freepascal.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 993fe7639216..fef1cc9fc803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ _build_docs=0
pkgbase='fpc-svn'
pkgname=('fpc-svn' 'fpc-src-svn')
-[ $_build_docs -ne 0 ] && pkgname+=('fpc-docs-svn')
-pkgver=3.1.1.r37950
+[[ $_build_docs -ne 0 ]] && pkgname+=('fpc-docs-svn')
+pkgver=3.1.1.r38855
_pkgver=${pkgver%.r*}
pkgrel=1
arch=('i686' 'x86_64')
@@ -22,9 +22,9 @@ license=('GPL' 'LGPL' 'custom')
depends=('ncurses' 'zlib' 'expat')
# Trunk can only be built with stable version of FPC
makedepends=('fpc<9999' 'subversion')
-[ $_build_docs -ne 0 ] && makedepends+=('texlive-core' 'texlive-htmlxml'
- 'texlive-latexextra' 'ghostscript')
-source=(fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk)
+[[ $_build_docs -ne 0 ]] && makedepends+=('texlive-core' 'texlive-htmlxml'
+ 'texlive-latexextra' 'ghostscript')
+source=('fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk')
sha1sums=('SKIP')
pkgver() {
@@ -41,8 +41,10 @@ build() {
popd
make NOGDB=1 OPT=' -dRelease' build
- cd fpcdocs
- [ $_build_docs -ne 0 ] && make -j1 FPCSRCDIR="${srcdir}"/fpcbuild/fpcsrc html
+ if [[ $_build_docs -ne 0 ]]; then
+ cd fpcdocs
+ make -j1 FPCSRCDIR="${srcdir}"/fpcbuild/fpcsrc html
+ fi
}
package_fpc-svn() {