summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLe Duc Hieu2015-06-13 12:29:55 +0700
committerLe Duc Hieu2015-06-13 12:29:55 +0700
commitcec092c3f324e0db94cb922439aa9221e119b716 (patch)
tree1846af7cb40f817e59d6ed5ab5e0ca593be793cf
downloadaur-cec092c3f324e0db94cb922439aa9221e119b716.tar.gz
initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD77
-rw-r--r--fp.cfg47
-rw-r--r--fp.dskbin0 -> 1969 bytes
-rw-r--r--fp.ini44
5 files changed, 198 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ca6351e30f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = fpc-svn
+ pkgver = 3.1.1.r31028
+ pkgrel = 1
+ url = http://www.freepascal.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ makedepends = fpc
+ depends = ncurses
+ depends = zlib
+ depends = expat
+ source = fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk
+ sha1sums = SKIP
+
+pkgname = fpc-svn
+ pkgdesc = The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible 32bit Pascal Compiler. It comes with fully TP 7.0 compatible run-time library.
+ provides = fpc
+ conflicts = fpc
+ options = zipman
+ options = staticlibs
+ backup = etc/fpc.cfg
+
+pkgname = fpc-src-svn
+ pkgdesc = Sources for the FreePascal compiler (required by the Lazarus IDE)
+ provides = fpc-src
+ conflicts = fpc-src
+ options = !strip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcbd50b720ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: L <alaviss 0 at gmail dot com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Valeriy Lyasotskiy <onestep@ukr.net>
+# Contributor: Jan Willemson <janwil@hot.ee>
+# Contributor: Hugo Ideler <hugoideler@dse.nl>
+# Contributor: BlackIkeEagle <ike DOT devolder AT gmail DOT com>
+# Original PKGBUILD: Andre Naumann <anaumann@SPARCed.org>
+# See http://bbs.archlinux.org/viewtopic.php?t=9318&highlight=fpc
+
+pkgbase=fpc-svn
+pkgname=(fpc-svn fpc-src-svn)
+pkgver=3.1.1.r31028
+_pkgver=${pkgver/${pkgver:5}}
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.freepascal.org/"
+license=('GPL' 'LGPL' 'custom')
+depends=(ncurses zlib expat)
+makedepends=(fpc)
+source=(fpcbuild::svn+http://svn.freepascal.org/svn/fpcbuild/trunk)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fpcbuild/fpcsrc"
+ printf "%s.r%s" \
+ $(grep -m1 version Makefile.fpc |sed 's/version=//') \
+ $(svnversion)
+}
+
+build() {
+ cd "${srcdir}/fpcbuild"
+ pushd fpcsrc/compiler
+ fpcmake -Tall
+ popd
+ make ${MAKEFLAGS} build NOGDB=1 # OPT=" -CX -Xs -XX -dRelease"
+}
+
+package_fpc-svn() {
+ pkgdesc="The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible 32bit Pascal Compiler. It comes with fully TP 7.0 compatible run-time library."
+ backup=("etc/fpc.cfg")
+ options=(zipman staticlibs)
+ conflicts=(fpc)
+ provides=(fpc)
+
+ cd "${srcdir}/fpcbuild"
+
+ export HOME="$srcdir"
+
+ make -j1 PREFIX=${pkgdir}/usr install NOGDB=1 # OPT=" -Xs -XX -CX -dRelease"
+
+ export PATH="$pkgdir/usr/bin:$PATH"
+
+ install -Dm0644 fpcsrc/rtl/COPYING.FPC "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.FPC"
+
+ [ "$CARCH" = "i686" ] && ln -s /usr/lib/fpc/${_pkgver}/ppc386 "${pkgdir}/usr/bin/"
+ [ "$CARCH" = "x86_64" ] && ln -s /usr/lib/fpc/${_pkgver}/ppcx64 "${pkgdir}/usr/bin/"
+
+ mkdir -p "${pkgdir}/etc"
+ "${pkgdir}/usr/lib/fpc/${_pkgver}/samplecfg" "$pkgdir/usr/lib/fpc/${_pkgver}" "${pkgdir}/etc"
+
+ # use -fPIC by default
+ echo -e "#ifdef cpux86_64\n# for x86_64 use -fPIC by default\n-Cg\n#endif" >> "$pkgdir/etc/fpc.cfg"
+
+ mv "$pkgdir/usr/man" "$pkgdir/usr/share/"
+
+ find "$pkgdir/etc/" -type f -exec sed -i "s|$pkgdir||g" {} \;
+}
+
+package_fpc-src-svn() {
+ pkgdesc="Sources for the FreePascal compiler (required by the Lazarus IDE)"
+ options=(!strip)
+ conflicts=(fpc-src)
+ provides=(fpc-src)
+
+ mkdir -p $pkgdir/usr/lib/fpc
+ cp -r $srcdir/../fpcbuild/fpcsrc $pkgdir/usr/lib/fpc/src
+}
diff --git a/fp.cfg b/fp.cfg
new file mode 100644
index 000000000000..47409c1d2698
--- /dev/null
+++ b/fp.cfg
@@ -0,0 +1,47 @@
+# Automatically created file, don't edit.
+#IFDEF NORMAL
+ -TLinux
+ -Mfpc
+ -Sg
+ -Si
+ -Os
+ -CpATHLON64
+ -OpCOREI
+ -g-
+ -p-
+ -b-
+#ENDIF
+
+#IFDEF DEBUG
+ -TLinux
+ -Mfpc
+ -Sg
+ -Si
+ -Sa
+ -Cr
+ -Ci
+ -Co
+ -CR
+ -Os
+ -CpATHLON64
+ -OpCOREI
+ -g
+ -p-
+ -b-
+#ENDIF
+
+#IFDEF RELEASE
+ -TLinux
+ -Mfpc
+ -Sg
+ -Si
+ -CX
+ -Os
+ -CpATHLON64
+ -OpCOREI
+ -XS
+ -g-
+ -p-
+ -b-
+#ENDIF
+
diff --git a/fp.dsk b/fp.dsk
new file mode 100644
index 000000000000..b6c3dde98de9
--- /dev/null
+++ b/fp.dsk
Binary files differ
diff --git a/fp.ini b/fp.ini
new file mode 100644
index 000000000000..7de6a10fc96d
--- /dev/null
+++ b/fp.ini
@@ -0,0 +1,44 @@
+[Compile]
+CompileMode=NORMAL
+
+[Help]
+Files=""
+
+[Editor]
+DefaultTabSize=8
+DefaultIndentSize=1
+DefaultFlags=20599
+DefaultSaveExt=.pas
+
+[Highlight]
+Exts="*.pas;*.pp;*.inc;*.dpr;*.lpr"
+NeedsTabs="make*;make*.*;fpcmake.loc"
+
+[SourcePath]
+SourceList=""
+
+[Mouse]
+DoubleDelay=8
+ReverseButtons=0
+AltClickAction=6
+CtrlClickAction=1
+
+[Keyboard]
+EditKeys=microsoft
+
+[Search]
+FindFlags=4
+
+[Preferences]
+DesktopFileFlags=209
+CenterCurrentLineWhileDebugging=1
+AutoSaveFlags=6
+MiscOptions=6
+DesktopLocation=1
+
+[Misc]
+ShowReadme=0
+
+[Files]
+OpenExts="*.pas;*.pp;*.inc;*.dpr;*.lpr"
+PrinterDevice=prn