summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2018-09-14 17:03:21 +0300
committerDrobot Viktor2018-09-14 17:03:21 +0300
commit79536271fbb4d15bc03d3711320d843a4a71e9be (patch)
tree2b582dcd8a0d74dc9e56f985d8ab5490e3081ebd
downloadaur-79536271fbb4d15bc03d3711320d843a4a71e9be.tar.gz
The first release of fpocket
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--fpocket.patch26
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f680b722c9f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fpocket-git
+ pkgdesc = Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation
+ pkgver = 3.1.2
+ pkgrel = 1
+ url = https://github.com/Discngine/fpocket
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = patch
+ source = git+https://github.com/Discngine/fpocket.git
+ source = fpocket.patch
+ sha1sums = SKIP
+ sha1sums = 376060e821c23483effa2befb6e090d81dcc4d5e
+
+pkgname = fpocket-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eefda00d2b1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+pkgname=fpocket-git
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="https://github.com/Discngine/fpocket"
+makedepends=('git' 'patch')
+source=("git+https://github.com/Discngine/fpocket.git"
+ "fpocket.patch")
+sha1sums=('SKIP'
+ '376060e821c23483effa2befb6e090d81dcc4d5e')
+
+prepare() {
+ cd ${srcdir}/fpocket
+ patch -Np0 -i "${srcdir}/fpocket.patch"
+}
+
+build() {
+ cd ${srcdir}/fpocket
+
+ make
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/man/man8
+
+ cd ${srcdir}/fpocket
+
+ install -Dm755 bin/fpocket ${pkgdir}/usr/bin/fpocket
+ install -Dm755 bin/dpocket ${pkgdir}/usr/bin/dpocket
+ install -Dm755 bin/tpocket ${pkgdir}/usr/bin/tpocket
+ install -Dm755 bin/mdpocket ${pkgdir}/usr/bin/mdpocket
+ install -Dm644 man/fpocket.8 ${pkgdir}/usr/share/man/man8/fpocket.8
+ install -Dm644 man/dpocket.8 ${pkgdir}/usr/share/man/man8/dpocket.8
+ install -Dm644 man/tpocket.8 ${pkgdir}/usr/share/man/man8/tpocket.8
+}
diff --git a/fpocket.patch b/fpocket.patch
new file mode 100644
index 000000000000..14dc20324eda
--- /dev/null
+++ b/fpocket.patch
@@ -0,0 +1,26 @@
+--- makefile 2018-09-14 16:37:11.552447515 +0300
++++ makefile 2018-09-14 16:35:07.558785168 +0300
+@@ -38,7 +38,7 @@
+ QCFLAGS = -O -g -pg -ansi
+
+ LGSL = -L$(PATH_GSL)lib -lgsl -lgslcblas
+-LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lnetcdf -lstdc++
++LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lstdc++
+ #
+ #------------------------------------------------------------
+ # BINARIES OBJECTS
+--- src/mdpocket.c 2018-09-14 16:37:31.845834900 +0300
++++ src/mdpocket.c 2018-09-14 16:35:21.485488676 +0300
+@@ -92,10 +92,10 @@
+ char pdb_code[350] = "";
+
+
+- if (!strncmp(par->traj_format, "net", 3)) {
++/* if (!strncmp(par->traj_format, "net", 3)) {
+ molfile_netcdfplugin_init();
+ molfile_netcdfplugin_register(NULL, register_cb);
+- }
++ }*/
+ if (!strncmp(par->traj_format, "dcd", 3)) {
+ molfile_dcdplugin_init();
+ molfile_dcdplugin_register(NULL, register_cb);