summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmille2022-04-03 11:04:18 +0200
committerkmille2022-04-03 11:04:18 +0200
commit2e5bd295bd35a2c07d1370a4c031a48f1b51d7aa (patch)
tree4a98e5907ca0356b75e0f1a623d710168880e3d7
parent08297bd7c64fef0f21574025f7bcd1e2da95b1ab (diff)
downloadaur-2e5bd295bd35a2c07d1370a4c031a48f1b51d7aa.tar.gz
Fix -Werror=format-security erro during build
The compiler option was added recently and doesn't build us the software
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed761d7179db..061fc2ca69d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fprint_demo
pkgdesc = A simple GTK+ application to demonstrate and test libfprint's capabilities
pkgver = 0.4
- pkgrel = 2
+ pkgrel = 3
url = https://www.freedesktop.org/wiki/Software/fprint/fprint_demo/
arch = i686
arch = x86_64
@@ -14,4 +14,3 @@ pkgbase = fprint_demo
md5sums = 41e78e420716f300b8776047b3c9fc5b
pkgname = fprint_demo
-
diff --git a/PKGBUILD b/PKGBUILD
index a2c7902f3bab..a59e3b801185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fprint_demo
pkgver=0.4
-pkgrel=2
+pkgrel=3
pkgdesc='A simple GTK+ application to demonstrate and test libfprint'"'"'s capabilities'
arch=('i686' 'x86_64')
url='https://www.freedesktop.org/wiki/Software/fprint/fprint_demo/'
@@ -18,6 +18,9 @@ prepare() {
cd "${pkgname}-${pkgver}"
sed -i 's|libfprint|libfprint-0|' configure.ac
sed -i 's|include <libfprint/|include <libfprint-0/|g' src/{*.c,*.h}
+
+ # fix: -Werror=format-security
+ sed -i 's|GTK_BUTTONS_CLOSE, error->message);|GTK_BUTTONS_CLOSE, "%s", error->message);|' src/verify.c
}
build() {