summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2017-07-24 11:16:05 +0800
committerZhang Hai2017-07-24 11:16:05 +0800
commit93a2bf550d7045a51e131f5b99bf813f45f8aa3e (patch)
treea241a8cf13a00cf606a47974d1b279aa23d0df91
downloadaur-93a2bf550d7045a51e131f5b99bf813f45f8aa3e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85b237373a83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jul 24 03:14:11 UTC 2017
+pkgbase = fprint_demo
+ pkgdesc = A simple GTK+ application to demonstrate and test libfprint's capabilities
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fprint/fprint_demo/
+ arch = i686
+ arch = x86_64
+ groups = fprint-git
+ license = GPL2
+ makedepends = git
+ depends = gtk2
+ depends = libfprint
+ source = https://github.com/dsd/fprint_demo/archive/v0.4.tar.gz
+ md5sums = 41e78e420716f300b8776047b3c9fc5b
+
+pkgname = fprint_demo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..953400201c29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Zhang Hai <dreaming.in.code.zh@gmail.com>
+
+pkgname=fprint_demo
+pkgver=0.4
+pkgrel=1
+pkgdesc='A simple GTK+ application to demonstrate and test libfprint'"'"'s capabilities'
+arch=('i686' 'x86_64')
+url='https://www.freedesktop.org/wiki/Software/fprint/fprint_demo/'
+license=('GPL2')
+depends=('gtk2' 'libfprint')
+makedepends=(git)
+groups=(fprint-git)
+source=('https://github.com/dsd/fprint_demo/archive/v0.4.tar.gz')
+md5sums=('41e78e420716f300b8776047b3c9fc5b')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}