summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-10-31 21:33:10 +0100
committerj.r2021-10-31 21:33:10 +0100
commit1733198ac3d0025187fb6fba0f43720586c4c779 (patch)
tree5e690854d0c7c0caf94bf97b38f4f13ae978b703
parent0439a45605dbec61e389d045a16df43b9c05a45f (diff)
downloadaur-1733198ac3d0025187fb6fba0f43720586c4c779.tar.gz
fprintd-clients: fix error with latest meson
-rw-r--r--.SRCINFO11
-rw-r--r--0001-disable-systemd-reactivated.diff (renamed from disable-systemd-reactivated.diff)0
-rw-r--r--0002-Remove-ignored-positional-arguments.patch26
-rw-r--r--PKGBUILD17
4 files changed, 43 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e8b1d6e26e..cbf2e9b7f338 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fprintd-clients
pkgdesc = Fprintd without the daemon
pkgver = 1.90.1.r2.g54e56d6
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.freedesktop.org/uunicorn/fprintd
arch = x86_64
license = GPL
@@ -21,9 +21,11 @@ pkgbase = fprintd-clients
conflicts = fprintd
conflicts = fprintd-clients
source = fprintd-clients::git+https://gitlab.freedesktop.org/uunicorn/fprintd.git#branch=debian/clients-only
- source = disable-systemd-reactivated.diff
- md5sums = SKIP
- md5sums = b392087f0a6a824fcbceec21d2a38402
+ source = 0001-disable-systemd-reactivated.diff
+ source = 0002-Remove-ignored-positional-arguments.patch
+ sha256sums = SKIP
+ sha256sums = 05e537a783302f0b01984eee00368deb2bc846bfd16b8892a21aff79c9b7a6ab
+ sha256sums = 83458c77fd9b1c3022ed7230b92432a3edde00cc811a01e49b76c04629534b82
pkgname = fprintd-clients
depends = glib2
@@ -33,4 +35,3 @@ pkgname = fprintd-clients
depends = dbus-glib
depends = libsystemd
depends = libfprint-2.so
-
diff --git a/disable-systemd-reactivated.diff b/0001-disable-systemd-reactivated.diff
index 965b0165f704..965b0165f704 100644
--- a/disable-systemd-reactivated.diff
+++ b/0001-disable-systemd-reactivated.diff
diff --git a/0002-Remove-ignored-positional-arguments.patch b/0002-Remove-ignored-positional-arguments.patch
new file mode 100644
index 000000000000..f253c7721529
--- /dev/null
+++ b/0002-Remove-ignored-positional-arguments.patch
@@ -0,0 +1,26 @@
+From 968864ccfc0ab6cf7543134382eea08f172ecf30 Mon Sep 17 00:00:00 2001
+From: "j.r" <j.r@jugendhacker.de>
+Date: Sun, 31 Oct 2021 21:12:22 +0100
+Subject: [PATCH] Remove ignored positional arguments
+
+Actually newer meson versions make it fail
+---
+ data/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index bada139..2acefc0 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -22,7 +22,7 @@ configure_file(
+ )
+
+ polkit_policy = 'net.reactivated.fprint.device.policy'
+-polkit_policy_target = i18n.merge_file(polkit_policy,
++polkit_policy_target = i18n.merge_file(
+ input: '@0@.in'.format(polkit_policy),
+ output: polkit_policy,
+ po_dir: meson.source_root() / 'po',
+--
+2.33.1
+
diff --git a/PKGBUILD b/PKGBUILD
index d37c587d298f..b587b4ad1fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Matthew Murray <matt@mattmurr.xyz>
pkgname=fprintd-clients
pkgver=1.90.1.r2.g54e56d6
-pkgrel=3
+pkgrel=4
pkgdesc='Fprintd without the daemon'
arch=(x86_64)
license=('GPL')
@@ -12,7 +12,8 @@ conflicts=(fprintd fprintd-clients)
provides=($pkgname)
url="https://gitlab.freedesktop.org/uunicorn/fprintd"
source=("${pkgname}::git+${url}.git#branch=debian/clients-only"
- '0001-disable-systemd-reactivated.diff')
+ '0001-disable-systemd-reactivated.diff'
+ '0002-Remove-ignored-positional-arguments.patch')
pkgver() {
cd "$pkgname"
@@ -20,13 +21,14 @@ pkgver() {
}
prepare() {
- cd $pkgname
+ cd "$pkgname"
git checkout 54e56d660bf9730f8abc8f2c6a358ef2fec675f2
- patch -Np1 < $srcdir/disable-systemd-reactivated.diff
+ patch -Np1 -i "$srcdir/0001-disable-systemd-reactivated.diff"
+ patch -Np1 -i "$srcdir/0002-Remove-ignored-positional-arguments.patch"
}
build() {
- arch-meson $pkgname build \
+ arch-meson "$pkgname" build \
-D pam_modules_dir=/usr/lib/security
meson compile -C build
}
@@ -38,6 +40,9 @@ check() {
package() {
depends+=(libfprint-2.so)
- DESTDIR=$pkgdir meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
install -d -m 700 "${pkgdir}/var/lib/fprint"
}
+sha256sums=('SKIP'
+ '05e537a783302f0b01984eee00368deb2bc846bfd16b8892a21aff79c9b7a6ab'
+ '83458c77fd9b1c3022ed7230b92432a3edde00cc811a01e49b76c04629534b82')