summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-10-15 02:55:05 -0400
committerTimothy Gu2020-10-15 02:55:05 -0400
commit13bf7bbf35b09ae94b81b770261eb125cc82e6cf (patch)
tree60acc0fce1d31405da20dd55509796370fe2245f
parent5b3785f62949a46a99285490e283ea6ddb5d28e4 (diff)
downloadaur-13bf7bbf35b09ae94b81b770261eb125cc82e6cf.tar.gz
Fix versioning; make systemd unit file less restrictive
-rw-r--r--.SRCINFO7
-rw-r--r--0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch4
-rw-r--r--0002-data-Remove-TasksMax.patch26
-rw-r--r--PKGBUILD12
4 files changed, 41 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 780b1479baa2..6172a4f62597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = fprintd-libfprint2
pkgdesc = D-Bus service to access fingerprint readers
- pkgver = 1.90.1+98+gceb7544
+ pkgver = 1.90.1+97+gc42e627
pkgrel = 1
+ epoch = 1
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
groups = fprint
@@ -26,8 +27,10 @@ pkgbase = fprintd-libfprint2
conflicts = fprintd
source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git
source = 0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
+ source = 0002-data-Remove-TasksMax.patch
sha256sums = SKIP
- sha256sums = 3217fc8eac1aed68039a56380ce78b7efb16e9d0e9a99efccd78d88d57d1999b
+ sha256sums = 66f5f73676bcdc36b92c23923180c0a96f70f57b643e2b5d158494f1d0fb7ce5
+ sha256sums = a1d4577633e931d58fb9b3421558b58391218abee0d93ec4c4778d29d5ccfd87
pkgname = fprintd-libfprint2
depends = dbus
diff --git a/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch b/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
index 2d596c8bd346..c23d348e0a9c 100644
--- a/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
+++ b/0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch
@@ -1,7 +1,7 @@
-From 657bfff2871b95ab979d624e2668d7d472d5344b Mon Sep 17 00:00:00 2001
+From 42cb14080bbb6acb8dbbb98f1a1f454f794692ed Mon Sep 17 00:00:00 2001
From: Timothy Gu <timothygu99@gmail.com>
Date: Thu, 15 Oct 2020 02:29:49 -0400
-Subject: [PATCH] tests: Skip a test if virtual image driver is not enabled
+Subject: [PATCH 1/2] tests: Skip a test if virtual image driver is not enabled
test_manager_get_devices_on_name_appeared requires the virtual image
driver to be available.
diff --git a/0002-data-Remove-TasksMax.patch b/0002-data-Remove-TasksMax.patch
new file mode 100644
index 000000000000..275035c8ba07
--- /dev/null
+++ b/0002-data-Remove-TasksMax.patch
@@ -0,0 +1,26 @@
+From f3c2ecae6b0d2ab4bbe52dad8f7bd9b050b81bbd Mon Sep 17 00:00:00 2001
+From: Timothy Gu <timothygu99@gmail.com>
+Date: Thu, 15 Oct 2020 02:38:59 -0400
+Subject: [PATCH 2/2] data: Remove TasksMax
+
+fprintd can spawn new threads like the gmain thread, and the gusb
+library can spawn more threads of its own.
+---
+ data/fprintd.service.in | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/data/fprintd.service.in b/data/fprintd.service.in
+index daca723..b61d36b 100644
+--- a/data/fprintd.service.in
++++ b/data/fprintd.service.in
+@@ -33,7 +33,6 @@ RestrictRealtime=true
+
+ # Privilege escalation
+ NoNewPrivileges=true
+-TasksMax=1
+
+ # Capabilities
+ CapabilityBoundingSet=
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 6232243c210d..572b3ddd134d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,8 @@
pkgname=fprintd-libfprint2
_pkgname=fprintd
-pkgver=1.90.1+98+gceb7544
+epoch=1
+pkgver=1.90.1+97+gc42e627
pkgrel=1
pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
@@ -20,9 +21,11 @@ makedepends=(git gtk-doc meson pam)
checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git"
- '0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch')
+ '0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch'
+ '0002-data-Remove-TasksMax.patch')
sha256sums=('SKIP'
- '3217fc8eac1aed68039a56380ce78b7efb16e9d0e9a99efccd78d88d57d1999b')
+ '66f5f73676bcdc36b92c23923180c0a96f70f57b643e2b5d158494f1d0fb7ce5'
+ 'a1d4577633e931d58fb9b3421558b58391218abee0d93ec4c4778d29d5ccfd87')
pkgver() {
cd $_pkgname
@@ -31,7 +34,8 @@ pkgver() {
prepare() {
cd $_pkgname
- git am < '../0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch'
+ git apply < '../0001-tests-Skip-a-test-if-virtual-image-driver-is-not-ena.patch'
+ git apply < '../0002-data-Remove-TasksMax.patch'
}
build() {