summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Gu2020-03-19 23:53:58 -0400
committerTimothy Gu2020-03-19 23:53:58 -0400
commit6142d451ba0a2e4a1ce332f1ea518f2e3f713170 (patch)
treed8362d905603bc50af6a0baa35b6d53c937d34f3
parent33b7a43aadfcd4fac8ccddd65a677da67c7df358 (diff)
downloadaur-6142d451ba0a2e4a1ce332f1ea518f2e3f713170.tar.gz
Bump to 1.90.1+61+gd27872f; use official pam_wrapper
The AUR python-pypamtest package will be removed soon.
-rw-r--r--.SRCINFO10
-rw-r--r--53.patch55
-rw-r--r--54.patch25
-rw-r--r--PKGBUILD23
4 files changed, 99 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f94a6e464452..0fa807dd4eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fprintd-libfprint2
pkgdesc = D-Bus service to access fingerprint readers
- pkgver = 1.90.1+12+g750a815
- pkgrel = 2
+ pkgver = 1.90.1+61+gd27872f
+ pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
groups = fprint
license = GPL
+ checkdepends = pam_wrapper
checkdepends = python-cairo
checkdepends = python-dbus
checkdepends = python-dbusmock
checkdepends = python-gobject
- checkdepends = python-pypamtest
makedepends = intltool
makedepends = git
makedepends = gtk-doc
@@ -23,8 +23,12 @@ pkgbase = fprintd-libfprint2
provides = fprintd
conflicts = fprintd
source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git
+ source = 53.patch
+ source = 54.patch
source = disable-systemd-protection.patch
sha256sums = SKIP
+ sha256sums = d64ace799a6c6a3ea4ee56be104b3bdba6fe913329c25672205e2a3ebb897e6a
+ sha256sums = 1121efbc74182c8c742397581f78d9f1b0388487617434b81fc7f9abea1a3832
sha256sums = 4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1
pkgname = fprintd-libfprint2
diff --git a/53.patch b/53.patch
new file mode 100644
index 000000000000..09474e200ef2
--- /dev/null
+++ b/53.patch
@@ -0,0 +1,55 @@
+From c8a4e106301fba41796f2ae4ca9514be20f6bb97 Mon Sep 17 00:00:00 2001
+From: Timothy Gu <timothygu99@gmail.com>
+Date: Thu, 19 Mar 2020 23:27:15 -0400
+Subject: [PATCH 1/2] tests/fprintd: Allow tests to run even when virtual
+ device is not available
+
+Regression since 0fb4f3b0217ac0fe2ac7a65a5ff2abed68d74a53, which
+consistently removes self.device rather than setting it to None.
+---
+ tests/fprintd.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/fprintd.py b/tests/fprintd.py
+index 1bbc38b..5d9a329 100755
+--- a/tests/fprintd.py
++++ b/tests/fprintd.py
+@@ -318,7 +318,7 @@ class FPrintdVirtualDeviceBaseTest(FPrintdTest):
+ self.polkitd_start()
+ self.daemon_start()
+
+- if self.device is None:
++ if not hasattr(self, 'device'):
+ self.skipTest("Need virtual_image device to run the test")
+
+ self._polkitd_obj.SetAllowed(['net.reactivated.fprint.device.setusername',
+--
+2.24.1
+
+
+From 418e1391f760a58c0bae3aeec43e3fa81874b6ba Mon Sep 17 00:00:00 2001
+From: Timothy Gu <timothygu99@gmail.com>
+Date: Thu, 19 Mar 2020 23:29:42 -0400
+Subject: [PATCH 2/2] tests/fprintd: Increase allowed timeout
+
+On my laptop it takes 48 seconds to run, even when virtual device is not
+available.
+---
+ tests/meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 5f84d5b..7e0701d 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -18,6 +18,7 @@ foreach t: tests
+ 'FPRINT_BUILD_DIR=' + meson.build_root() / 'src',
+ 'TOPSRCDIR=' + meson.source_root(),
+ ],
++ timeout: t == 'fprintd' ? 60 : 30,
+ )
+ endforeach
+
+--
+2.24.1
+
diff --git a/54.patch b/54.patch
new file mode 100644
index 000000000000..3885ff549c0c
--- /dev/null
+++ b/54.patch
@@ -0,0 +1,25 @@
+From e828ea3b2d7437bc5adc671e50261c05108b328a Mon Sep 17 00:00:00 2001
+From: Timothy Gu <timothygu99@gmail.com>
+Date: Thu, 6 Feb 2020 10:25:54 -0800
+Subject: [PATCH] main: Add missing locale.h include
+
+The include is present in all other binaries in utils/.
+---
+ src/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/main.c b/src/main.c
+index a7db66d..1ecf431 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -19,6 +19,7 @@
+
+ #include "config.h"
+
++#include <locale.h>
+ #include <poll.h>
+ #include <stdlib.h>
+
+--
+2.24.1
+
diff --git a/PKGBUILD b/PKGBUILD
index ce7c6b723410..edf1fd969916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=fprintd-libfprint2
_pkgname=fprintd
-pkgver=1.90.1+12+g750a815
-pkgrel=2
+pkgver=1.90.1+61+gd27872f
+pkgrel=1
pkgdesc="D-Bus service to access fingerprint readers"
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
@@ -16,16 +16,16 @@ optdepends=('pam: to use the fprintd pam plugin')
provides=(fprintd)
conflicts=(fprintd)
makedepends=(intltool git gtk-doc meson pam)
-checkdepends=(python-cairo python-dbus python-dbusmock python-gobject python-pypamtest)
+checkdepends=(pam_wrapper python-cairo python-dbus python-dbusmock python-gobject)
groups=(fprint)
-source=(
- "git+https://gitlab.freedesktop.org/libfprint/fprintd.git"
- 'disable-systemd-protection.patch'
-)
-sha256sums=(
- 'SKIP'
- '4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1'
-)
+source=("git+https://gitlab.freedesktop.org/libfprint/$_pkgname.git"
+ '53.patch'
+ '54.patch'
+ 'disable-systemd-protection.patch')
+sha256sums=('SKIP'
+ 'd64ace799a6c6a3ea4ee56be104b3bdba6fe913329c25672205e2a3ebb897e6a'
+ '1121efbc74182c8c742397581f78d9f1b0388487617434b81fc7f9abea1a3832'
+ '4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1')
pkgver() {
cd $_pkgname
@@ -34,6 +34,7 @@ pkgver() {
prepare() {
cd $_pkgname
+ git apply "$srcdir/53.patch" "$srcdir/54.patch"
patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
}