summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen2020-01-27 21:45:42 -0800
committerStephen2020-01-27 21:45:42 -0800
commita1e42ffc3461335c4e55a3f7a6ec7be44e395076 (patch)
tree41305f1b0c45c875373bde4e9cb8928a2fa65598
parent5076c5bddc890086608fff67599b823802c2c6dc (diff)
downloadaur-a1e42ffc3461335c4e55a3f7a6ec7be44e395076.tar.gz
Fixup building in arch and disable pam tests for now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
-rw-r--r--disable_pam_tests.patch22
-rw-r--r--storage_fix.patch13
4 files changed, 49 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1de47323556..090fc8fa6ef0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fprintd-libfprint2
pkgdesc = D-Bus service to access fingerprint readers, modified for libfprint2
- pkgver = 0.9.0+33+g1a5ef6c
+ pkgver = 0.9.0+70+gb97903f
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f24e82489dcf..f10efbfa02b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=fprintd-libfprint2
pkgname_=fprintd
-pkgver=0.9.0+33+g1a5ef6c
+pkgver=0.9.0+70+gb97903f
pkgrel=1
pkgdesc="D-Bus service to access fingerprint readers, modified to use libfprint2"
arch=(x86_64)
@@ -20,17 +20,16 @@ groups=(fprint)
source=(
"git+https://gitlab.freedesktop.org/libfprint/fprintd.git"
'disable-systemd-protection.patch'
+ 'storage_fix.patch'
+ 'disable_pam_tests.patch'
)
sha256sums=(
'SKIP'
'4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1'
+ '2c81b9f4c5e593ee3ebdca08584be4b42c7a1a33f240c0da6e2aab50f0ff4b5c'
+ 'e94a80acaccc0e4830595b575f3865ed86a9866c18f910a83b568f602c750e3d'
)
-check() {
- cd $pkgname_
- make check
-}
-
pkgver() {
cd $pkgname_
git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
@@ -39,9 +38,17 @@ pkgver() {
prepare() {
cd $pkgname_
patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
+ patch -p1 -i "${srcdir}/storage_fix.patch"
+ patch -p1 -i "${srcdir}/disable_pam_tests.patch"
NOCONFIGURE=1 ./autogen.sh
}
+check() {
+ cd $pkgname_
+ make check
+}
+
+
build() {
cd $pkgname_
./configure \
diff --git a/disable_pam_tests.patch b/disable_pam_tests.patch
new file mode 100644
index 000000000000..d25f26fc3190
--- /dev/null
+++ b/disable_pam_tests.patch
@@ -0,0 +1,22 @@
+diff --git a/configure.ac b/configure.ac
+index 4922abd..6b5f425 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -91,7 +91,5 @@ doc/Makefile
+ doc/version.xml
+ doc/dbus/Makefile
+ tests/Makefile
+-tests/pam/Makefile
+-tests/pam/services/Makefile
+ po/Makefile.in
+ ])
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 3c9f3f5..8280236 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -1,5 +1,3 @@
+-SUBDIRS = pam
+-
+ TESTS_ENVIRONMENT = export FPRINT_BUILD_DIR=$(abs_top_builddir)/src; export TOPSRCDIR=$(abs_top_srcdir); export PYTHON=@PYTHON@;
+ TESTS = fprintd.py test_fprintd_utils.py
+
diff --git a/storage_fix.patch b/storage_fix.patch
new file mode 100644
index 000000000000..db7a0f92fa75
--- /dev/null
+++ b/storage_fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/device.c b/src/device.c
+index b4dfbc4..cb2edc1 100644
+--- a/src/device.c
++++ b/src/device.c
+@@ -34,6 +34,8 @@
+ #include "fprintd.h"
+ #include "storage.h"
+
++fp_storage store;
++
+ static char *fingers[] = {
+ [FP_FINGER_UNKNOWN] = "unknown",
+ "left-thumb",