summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bird2019-12-04 20:54:23 -0800
committerStephen Bird2019-12-04 21:06:45 -0800
commitb92e2caa2f9d332c9fcc665a5ec640ac6c95de65 (patch)
treebea9eefdea873bddb3246875defba5ad47175ec9
downloadaur-b92e2caa2f9d332c9fcc665a5ec640ac6c95de65.tar.gz
Initial package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD56
-rw-r--r--disable-systemd-protection.patch18
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c88d80c22828
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = fprintd-libfprint2
+ pkgdesc = D-Bus service to access fingerprint readers, modified for libfprint2
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
+ arch = x86_64
+ groups = fprint
+ license = GPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gnome-common
+ makedepends = git
+ makedepends = python-dbusmock
+ depends = libfprint-git
+ depends = dbus-glib
+ depends = polkit
+ conflicts = fprintd
+ source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=9e32cd525724f21eebf2336a06b13a39c6616ab0
+ source = disable-systemd-protection.patch
+ sha256sums = SKIP
+ sha256sums = 4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1
+
+pkgname = fprintd-libfprint2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86ba15c2cb1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Nikolay Rysev <mad.f3ka@gmail.com>
+# Modified for vfs_proprietary by Daniel Kamil Kozar <dkk089@gmail.com>
+# Modified for libfprint2 by Stephen Bird <sebirdman@gmail.com>
+
+pkgname=fprintd-libfprint2
+pkgname_=fprintd
+pkgver=0.9.0+18+g5043ef3
+pkgrel=1
+pkgdesc="D-Bus service to access fingerprint readers, modified to use libfprint2"
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
+license=(GPL)
+depends=(dbus-glib polkit libfprint-git)
+conflicts=(fprintd)
+makedepends=(intltool gtk-doc gnome-common git python-dbusmock)
+groups=(fprint)
+_commit=5043ef3c7d193adf103f356dbb0eeafbef0bc8c9
+source=(
+ "git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=$_commit"
+ 'disable-systemd-protection.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '4854d32d6579de31fd59b4df02f6a29db2e266dedfe9edda13bedcda1b083be1'
+)
+
+pkgver() {
+ cd $pkgname_
+ git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $pkgname_
+ patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname_
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd $pkgname_
+ make DESTDIR="$pkgdir" dbus_confdir=/usr/share/dbus-1/system.d install
+ install -d -m 755 "$pkgdir/var/lib/fprint"
+}
diff --git a/disable-systemd-protection.patch b/disable-systemd-protection.patch
new file mode 100644
index 000000000000..e644df6096c6
--- /dev/null
+++ b/disable-systemd-protection.patch
@@ -0,0 +1,18 @@
+diff --git a/data/fprintd.service.in b/data/fprintd.service.in
+index 9ea7a2a..0828fe8 100644
+--- a/data/fprintd.service.in
++++ b/data/fprintd.service.in
+@@ -8,13 +8,11 @@ BusName=net.reactivated.Fprint
+ ExecStart=@libexecdir@/fprintd
+
+ # Filesystem lockdown
+-ProtectSystem=strict
+ ProtectKernelTunables=true
+ ProtectControlGroups=true
+ # This always corresponds to /var/lib/fprint
+ StateDirectory=fprint
+ ProtectHome=true
+-PrivateTmp=true
+
+ # Network
+ PrivateNetwork=true