summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:48 -0400
committerKevin MacMartin2015-06-10 00:37:48 -0400
commit39649f56fabb489207e9852a8b6a536de08a925f (patch)
tree0d92090fc033d2b5dc30350021adb9d1d7131e02
downloadaur-39649f56fabb489207e9852a8b6a536de08a925f.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--fractalnow.install7
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..313b8626c5cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fractalnow
+ pkgdesc = Provides users with tools to generate pictures of various types of fractals quickly and easily.
+ pkgver = 0.8.1
+ pkgrel = 2
+ url = http://sourceforge.net/projects/fractalnow
+ install = fractalnow.install
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = qt4
+ depends = libmpc
+ source = http://downloads.sourceforge.net/project/fractalnow/FractalNow/0.8.1/sources/fractalnow-0.8.1.tar.gz
+ sha512sums = c9af974ad007655f97eb02af39963d123661276ba6847314d7f5e95ee044a0059570a4e7dd0b11fe4fce498b1f1405eea44ab6082e0ef733d30d9f18228813bd
+
+pkgname = fractalnow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4e4ffbf0120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Prurigro
+
+pkgname=fractalnow
+pkgver=0.8.1
+pkgrel=2
+pkgdesc="Provides users with tools to generate pictures of various types of fractals quickly and easily."
+url="http://sourceforge.net/projects/fractalnow"
+license=('LGPL3')
+depends=('qt4' 'libmpc')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/project/fractalnow/FractalNow/0.8.1/sources/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('c9af974ad007655f97eb02af39963d123661276ba6847314d7f5e95ee044a0059570a4e7dd0b11fe4fce498b1f1405eea44ab6082e0ef733d30d9f18228813bd')
+install=${pkgname}.install
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ find . -type f -exec sed -i 's/qmake/qmake-qt4/g' '{}' \;
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure -prefix /usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ ESCPKGDIR=$(echo ${pkgdir} | sed "s/\//\\\\\//g" | sed "s/\ /\\\\ /g")
+ sed -e "s/PREFIX\ =\ \/usr"/"PREFIX\ =\ ${ESCPKGDIR}\/usr/g" Makefile > Makefile.tmp
+ mv Makefile Makefile.orig
+ mv Makefile.tmp Makefile
+ make install
+}
diff --git a/fractalnow.install b/fractalnow.install
new file mode 100644
index 000000000000..d52cd4b25522
--- /dev/null
+++ b/fractalnow.install
@@ -0,0 +1,7 @@
+post_install() {
+ gtk-update-icon-cache
+}
+
+post_upgrade() {
+ gtk-update-icon-cache
+}