summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Nowak2019-10-07 02:58:19 +0200
committerMarcin Nowak2019-10-07 02:58:19 +0200
commit8c615f5a778f467a5e3bd9f817900f2d81d91675 (patch)
treed909b778864aa84619b4c194106e856fadb102dd
downloadaur-8c615f5a778f467a5e3bd9f817900f2d81d91675.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rwxr-xr-xfractalus3
-rw-r--r--fractalus.desktop8
5 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ca15fe5bb06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fractalus
+ pkgdesc = A fan remake of Rescue on Fractalus, a classic game developed by Lucasfilm Games originally released on Atari, Commodore 64 and other platforms in 1984.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://www.lsdwa.com/projects/fractalus/
+ arch = x86_64
+ license = unknown
+ source = http://downloads.gcloud.lsdwa.com/projects/fractalus/fractalus-0.9.0-linux.tgz
+ source = fractalus.desktop
+ source = fractalus
+ sha256sums = 03c62dbb43aba31de19eb0f0662d77626eaf8aed06c02cfe6a539be585beb097
+ sha256sums = 2b6ed647553bc49888b5ad87e37e461b6cdae71c5b43ee396b52d41466a9c77d
+ sha256sums = d0c6d22e779f56add988a5343ed9521790b5d01d0d9ce0bf878455ffcdf4e013
+
+pkgname = fractalus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3fc7c18fcb93
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+/*.tar
+/*.tgz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2169537ee8a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marcin Nowak <marcin.j.nowak+aur AT gmail DOT com>
+
+pkgname=fractalus
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='A fan remake of Rescue on Fractalus, a classic game developed by Lucasfilm Games originally released on Atari, Commodore 64 and other platforms in 1984.'
+url=https://www.lsdwa.com/projects/fractalus/
+source=(
+ "http://downloads.gcloud.lsdwa.com/projects/fractalus/fractalus-$pkgver-linux.tgz"
+ "${pkgname}.desktop"
+ "fractalus"
+ )
+arch=('x86_64')
+sha256sums=(
+"03c62dbb43aba31de19eb0f0662d77626eaf8aed06c02cfe6a539be585beb097"
+"2b6ed647553bc49888b5ad87e37e461b6cdae71c5b43ee396b52d41466a9c77d"
+"d0c6d22e779f56add988a5343ed9521790b5d01d0d9ce0bf878455ffcdf4e013"
+)
+license=("unknown")
+
+package(){
+ install -dm755 ${pkgdir}/opt
+ install -dm755 ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -R * ${pkgdir}/opt/${pkgname}
+ chmod 755 ${pkgdir}/opt/${pkgname}
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/"
+}
diff --git a/fractalus b/fractalus
new file mode 100755
index 000000000000..31607daae7e2
--- /dev/null
+++ b/fractalus
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+cd /opt/fractalus/ && ./Fractalus.x86_64
diff --git a/fractalus.desktop b/fractalus.desktop
new file mode 100644
index 000000000000..bc98817a33ee
--- /dev/null
+++ b/fractalus.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Fractalus
+Comment=A fan remake of Rescue on Fractalus, a classic game developed by Lucasfilm Games originally released on Atari, Commodore 64 and other platforms in 1984.
+Exec=/opt/fractalus/Fractalus.x86_64
+Terminal=false
+Type=Application
+Categories=Games;
+StartupNotify=true