summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Mildenberger2015-07-25 00:26:22 +0200
committerPhilipp Mildenberger2015-07-25 00:26:22 +0200
commita12fe854ab488b60c54837a07c87d9543c0ed772 (patch)
tree741c828a4c1fcc28796726345a8b583befcfd7fc
downloadaur-a12fe854ab488b60c54837a07c87d9543c0ed772.tar.gz
Initial import and rewrite of the PKGBUILD to be up to date
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b42c8fcb3c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Fri Jul 24 22:21:14 UTC 2015
+pkgbase = fragmentarium-git
+ pkgdesc = Fragmentarium is an open source, cross-platform IDE for exploring pixel based graphics on the GPU
+ pkgver = 1.0.0.r19.144.g132c6b5
+ pkgrel = 1
+ url = http://syntopia.github.com/Fragmentarium/
+ arch = i686
+ arch = x86_64
+ license = GPL3 or LGPL 2.1
+ makedepends = git
+ depends = qt5-base
+ depends = mesa
+ provides = fragmentarium
+ conflicts = fragmentarium
+ source = git+https://github.com/Syntopia/Fragmentarium
+ md5sums = SKIP
+
+pkgname = fragmentarium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..231fbabdc5eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: <nixtrian@gmail.com>
+# Contributor: <philipp.mildenberger <- AT -> student.uibk.ac.at>
+
+pkgname="fragmentarium-git"
+_pkgname="fragmentarium"
+_gitname="Fragmentarium"
+pgksourcename="Fragmentarium-Source"
+pkgver=1.0.0.r19.144.g132c6b5
+pkgrel=1
+pkgdesc="Fragmentarium is an open source, cross-platform IDE for exploring pixel based graphics on the GPU"
+arch=('i686' 'x86_64')
+url="http://syntopia.github.com/Fragmentarium/"
+license=('GPL3 or LGPL 2.1')
+depends=('qt5-base' 'mesa')
+makedepends=("git")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("git+https://github.com/Syntopia/Fragmentarium")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/v//g' | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed "s/g/$(git rev-list --count HEAD).g/g"
+}
+
+build() {
+ cd "$_gitname/$pgksourcename"
+ qmake -project -after "CONFIG+=opengl" -after "QT+=xml opengl script"
+ qmake
+ make
+}
+
+
+package() {
+ cd "$_gitname/$pgksourcename"
+ install -d -m755 $pkgdir/usr/bin
+ install -m755 "$pgksourcename" "$pkgdir/usr/bin/fragmentarium"
+ install -d 755 "$pkgdir/usr/share/fragmentarium"
+ cp -rf "Examples" "Misc" $pkgdir/usr/share/fragmentarium/
+}