summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasith Gunawardhana2019-12-28 16:10:10 -0500
committerDasith Gunawardhana2019-12-28 16:10:10 -0500
commit17582a87108b870b021b6e6bf3e4b6e5e0866c88 (patch)
tree492bbc61d518c4ef36b503fd829739d0952e9b13
downloadaur-17582a87108b870b021b6e6bf3e4b6e5e0866c88.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8632905a58ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fraidycat-git
+ pkgdesc = Follow blogs, wikis, YouTube channels, as well as accounts on Twitter, Instagram, etc. from a single page.
+ pkgver = r76.76d1b26
+ pkgrel = 1
+ url = https://github.com/kickscondor/fraidycat
+ arch = x86_64
+ license = BlueOak-1.0.0
+ makedepends = npm
+ makedepends = git
+ makedepends = git-lfs
+ provides = fraidycat
+ conflicts = fraidycat
+
+pkgname = fraidycat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31619c1308b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Dasith Gunawardhana <dasith@dg10a.com>
+
+_pkgname=fraidycat
+pkgname=${_pkgname}-git
+pkgver=r76.76d1b26
+pkgrel=1
+pkgdesc="Follow blogs, wikis, YouTube channels, as well as accounts on Twitter, Instagram, etc. from a single page."
+arch=('x86_64')
+url="https://github.com/kickscondor/fraidycat"
+license=('BlueOak-1.0.0')
+makedepends=('npm' 'git' 'git-lfs')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+prepare() {
+ cd "$srcdir"
+
+ rm -rf ${_pkgname}
+ git clone https://github.com/kickscondor/fraidycat.git
+ cd "$srcdir/${_pkgname}"
+
+ git lfs install
+ git lfs pull
+ npm install
+}
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ npm run electron:linux
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ install -dm755 "${pkgdir}/usr/lib/${_pkgname}"
+ cp -dr --no-preserve=ownership dist/linux-unpacked/* "${pkgdir}/usr/lib/${_pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}