summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-12-08 00:05:12 +0100
committerMichal Wojdyla2021-12-08 00:05:12 +0100
commit7e21eadd308e49348ae3966ade1a03826d380510 (patch)
tree7044bca0342cbcb5cfd3785923dacce34fd152d8
parent5dc393ae5bb4e48412fb1073f32b37af2d1a0f76 (diff)
downloadaur-7e21eadd308e49348ae3966ade1a03826d380510.tar.gz
small update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36793c3ede21..e7f32ad5c9fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fraidycat-git
pkgdesc = Follow blogs, wikis, YouTube, Twitter, Reddit, Instagram and the like... from a distance.
- pkgver = 1.0.7.r2.g76d1b26
+ pkgver = 1.1.10.r0.ga5480cf
pkgrel = 1
url = https://fraidyc.at
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = fraidycat-git
optdepends = xdg-utils: open URLs with desktop's default (xdg-email, xdg-open)
provides = fraidycat
conflicts = fraidycat
+ source = git+https://github.com/kickscondor/fraidycat.git#branch=v1.1
+ md5sums = SKIP
pkgname = fraidycat-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7b9d2abad547..2eb103fa9119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Dasith Gunawardhana <dasith@dg10a.com>
+# Contributor: Dasith Gunawardhana <dasith@dg10a.com>
# Contributor: Mark Wagie <yochanan dot marqos at gmail dot com>
+export GIT_LFS_SKIP_SMUDGE=1 # This is to prevent Git LFS errors
_pkgname=fraidycat
pkgname=${_pkgname}-git
-pkgver=1.0.7.r2.g76d1b26
+pkgver=1.1.10.r0.ga5480cf
pkgrel=1
pkgdesc="Follow blogs, wikis, YouTube, Twitter, Reddit, Instagram and the like... from a distance."
arch=('x86_64')
@@ -14,16 +15,16 @@ optdepends=("xdg-utils: open URLs with desktop's default (xdg-email, xdg-open)")
makedepends=('npm' 'git' 'git-lfs' 'gendesk')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-
+source=(git+https://github.com/kickscondor/fraidycat.git#branch=v1.1)
+md5sums=('SKIP')
prepare() {
gendesk -f -n --name Fraidycat --pkgname "${_pkgname}" --pkgdesc "$pkgdesc" --exec="/opt/${_pkgname}/${_pkgname} %U" --categories 'News' --custom "StartupWMClass=Fraidycat"
-
- rm -rf "$srcdir/${_pkgname}"
-
- git clone https://github.com/kickscondor/fraidycat.git
+ unset GIT_LFS_SKIP_SMUDGE
cd "$srcdir/${_pkgname}"
+ git remote set-url origin https://github.com/kickscondor/fraidycat.git
git lfs install
- git lfs pull
+ git lfs fetch
+ git lfs checkout
}
pkgver() {