summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-17 23:57:12 +0800
committerzxp198210052024-01-17 23:57:12 +0800
commit155338d863e722de3ddb11e274d18bfa546f3395 (patch)
treec533ffc7ee63b16a838aba0cc543f22c8d772cd7
parent1aca0d9736c13b602a5c2e451b979ae5bcccc199 (diff)
downloadaur-155338d863e722de3ddb11e274d18bfa546f3395.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--frame-eth.sh13
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32387c46b2a8..dba25f1412ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frame-eth-bin
pkgdesc = System-wide Web3
pkgver = 0.6.8
- pkgrel = 2
+ pkgrel = 3
url = https://frame.sh/
arch = aarch64
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = frame-eth-bin
conflicts = frame-eth-dev
conflicts = frame-eth-canary
source = frame-eth.sh
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = frame-eth-0.6.8-aarch64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_arm64.deb
sha256sums_aarch64 = 92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b
source_x86_64 = frame-eth-0.6.8-x86_64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index fd7964e9125e..5d343f1b698f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname}-eth-bin"
_appname=Frame
pkgver=0.6.8
_electronversion=23
-pkgrel=2
+pkgrel=3
pkgdesc="System-wide Web3"
arch=("aarch64" "x86_64")
url="https://frame.sh/"
@@ -22,7 +22,7 @@ depends=(
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b')
sha256sums_x86_64=('356f81057f557f5f2ff945c1c215265933930484033525fe1c63a2fa511f41e2')
build() {
@@ -31,7 +31,7 @@ build() {
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed -e "s|/opt/${_appname}/${_pkgname} %U|${pkgname%-bin}|g" \
+ sed -e "s|/opt/${_appname}/${_pkgname}|${pkgname%-bin}|g" \
-e "s|Icon=${_pkgname}|${pkgname%-bin}|g" \
-i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
}
diff --git a/frame-eth.sh b/frame-eth.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/frame-eth.sh
+++ b/frame-eth.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file