summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-12 17:43:57 +0800
committerzxp198210052023-12-12 17:43:57 +0800
commit1aca0d9736c13b602a5c2e451b979ae5bcccc199 (patch)
tree2ed682b339ec1e8be93b623a23d930b04ac72395
parentc98e992af2b4a8362c387c609f5ccb979f218362 (diff)
downloadaur-1aca0d9736c13b602a5c2e451b979ae5bcccc199.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--frame-eth.sh16
3 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 311091683437..32387c46b2a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = frame-eth-bin
pkgdesc = System-wide Web3
pkgver = 0.6.8
- pkgrel = 1
+ pkgrel = 2
url = https://frame.sh/
arch = aarch64
arch = x86_64
license = GPL3
- depends = bash
depends = electron23
provides = frame-eth=0.6.8
conflicts = frame-eth
conflicts = frame-eth-dev
conflicts = frame-eth-canary
source = frame-eth.sh
- sha256sums = cf35f64affa2c15af5171d01f2ae63e124cc19264eca3f300268de95f079f564
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
source_aarch64 = frame-eth-0.6.8-aarch64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_arm64.deb
sha256sums_aarch64 = 92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b
source_x86_64 = frame-eth-0.6.8-x86_64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 9e6a86a249f5..fd7964e9125e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,33 @@ _pkgname=frame
pkgname="${_pkgname}-eth-bin"
_appname=Frame
pkgver=0.6.8
-pkgrel=1
+_electronversion=23
+pkgrel=2
pkgdesc="System-wide Web3"
arch=("aarch64" "x86_64")
url="https://frame.sh/"
_ghurl="https://github.com/floating/frame"
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-dev" "${pkgname%-bin}-canary")
-depends=('bash' 'electron23')
+conflicts=(
+ "${pkgname%-bin}"
+ "${pkgname%-bin}-dev"
+ "${pkgname%-bin}-canary"
+)
+depends=(
+ "electron${_electronversion}"
+)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('cf35f64affa2c15af5171d01f2ae63e124cc19264eca3f300268de95f079f564')
+sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
sha256sums_aarch64=('92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b')
sha256sums_x86_64=('356f81057f557f5f2ff945c1c215265933930484033525fe1c63a2fa511f41e2')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed -e "s|/opt/${_appname}/${_pkgname} %U|${pkgname%-bin}|g" \
-e "s|Icon=${_pkgname}|${pkgname%-bin}|g" \
diff --git a/frame-eth.sh b/frame-eth.sh
index dc4cad087718..2ec4412e5c4f 100644
--- a/frame-eth.sh
+++ b/frame-eth.sh
@@ -1,10 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron23
-APPDIR="/usr/lib/frame-eth"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file