summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-11 11:54:02 +0800
committerzxp198210052024-03-11 11:54:02 +0800
commit380efbd90aca02a8e3d05d708c7fefb27871ef8c (patch)
tree0e1e1e5c7b2cd6fb93cbcabb9caac2dae8c10e9d
parent9b7291eb3c80a2412fb3f3bcb98a09d31895013d (diff)
downloadaur-380efbd90aca02a8e3d05d708c7fefb27871ef8c.tar.gz
update to 0.6.9
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
-rw-r--r--frame-eth.sh8
3 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 198f8f26a288..145edf81a34d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = frame-eth-bin
pkgdesc = System-wide Web3
- pkgver = 0.6.8
- pkgrel = 4
+ pkgver = 0.6.9
+ pkgrel = 1
url = https://frame.sh/
arch = aarch64
arch = x86_64
license = GPL-3.0-only
depends = electron23
- provides = frame-eth=0.6.8
+ provides = frame-eth=0.6.9
conflicts = frame-eth
conflicts = frame-eth-dev
conflicts = frame-eth-canary
source = frame-eth.sh
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
- source_aarch64 = frame-eth-0.6.8-aarch64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_arm64.deb
- sha256sums_aarch64 = 92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b
- source_x86_64 = frame-eth-0.6.8-x86_64.deb::https://github.com/floating/frame/releases/download/v0.6.8/frame_0.6.8_amd64.deb
- sha256sums_x86_64 = 356f81057f557f5f2ff945c1c215265933930484033525fe1c63a2fa511f41e2
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ source_aarch64 = frame-eth-0.6.9-aarch64.deb::https://github.com/floating/frame/releases/download/v0.6.9/frame_0.6.9_arm64.deb
+ sha256sums_aarch64 = e4c8238d08392f1c36791749e8e160222cf7c865bfe97a55912bd306f7bf1870
+ source_x86_64 = frame-eth-0.6.9-x86_64.deb::https://github.com/floating/frame/releases/download/v0.6.9/frame_0.6.9_amd64.deb
+ sha256sums_x86_64 = d85bf8ac7c07419a35747628039c300b278424b76d5369d691eed48e0d9bf60d
pkgname = frame-eth-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6eae738b52ba..522b97d7373c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=frame
pkgname="${_pkgname}-eth-bin"
_appname=Frame
-pkgver=0.6.8
+pkgver=0.6.9
_electronversion=23
-pkgrel=4
+pkgrel=1
pkgdesc="System-wide Web3"
arch=(
"aarch64"
@@ -25,13 +25,14 @@ depends=(
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
-sha256sums_aarch64=('92dd36a4a68992985293aa796573877c33d8e4d1e036d2b2de167622aece374b')
-sha256sums_x86_64=('356f81057f557f5f2ff945c1c215265933930484033525fe1c63a2fa511f41e2')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+sha256sums_aarch64=('e4c8238d08392f1c36791749e8e160222cf7c865bfe97a55912bd306f7bf1870')
+sha256sums_x86_64=('d85bf8ac7c07419a35747628039c300b278424b76d5369d691eed48e0d9bf60d')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed -e "s|/opt/${_appname}/${_pkgname}|${pkgname%-bin}|g" \
diff --git a/frame-eth.sh b/frame-eth.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/frame-eth.sh
+++ b/frame-eth.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file