summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaettir2015-06-08 22:09:31 -0300
committerVaettir2015-06-08 22:09:31 -0300
commita5b81e67f2f379158cb1268e6f81a6d4ae14b583 (patch)
tree00dbd937a04a1958f99c6d131653056adf9beba8
downloadaur-frame3dd.tar.gz
Corrected checksum.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff472dcf1d4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = frame3dd
+ pkgdesc = Free open-source software for static and dynamic structural analysis of 2D and 3D frames and trusses.
+ pkgver = 0.20140514plus
+ pkgrel = 1
+ url = http://frame3dd.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ optdepends = gnuplot: plot results
+ source = http://sourceforge.net/projects/frame3dd/files/frame3dd/0.20140514+/Frame3DD_20140514+_src.zip
+ md5sums = 7991be807e04673381d5fa76424d74ab
+
+pkgname = frame3dd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7c6a1ba5175
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ricardo Leuck <leuck dot r at gmail dot com>
+pkgname=frame3dd
+pkgver=0.20140514plus
+pkgrel=1
+pkgdesc="Free open-source software for static and dynamic structural analysis of 2D and 3D frames and trusses."
+arch=('i686' 'x86_64')
+url="http://frame3dd.sourceforge.net/"
+license=('GPL3')
+depends=()
+optdepends=('gnuplot: plot results')
+source=(http://sourceforge.net/projects/$pkgname/files/$pkgname/0.20140514+/Frame3DD_20140514+_src.zip)
+md5sums=('143ae3cc6cec9057be081509148834a7')
+
+build() {
+ cd "$srcdir/Frame3DD/src"
+ make
+}
+
+package() {
+ # uncomment the next lines if you want the docs and examples
+ # cd "$srcdir/$pkgname-$pkgver"
+ # mkdir -p $pkgdir/usr/share/doc/$pkgname
+ # cp -r -t $pkgdir/usr/share/doc/$pkgname doc examples
+
+ cd "$srcdir/Frame3DD/src"
+ mkdir -p $pkgdir/usr/bin
+ cp frame3dd $pkgdir/usr/bin/
+
+}