summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:41:25 +0200
committerAntonio Rojas2015-06-08 22:41:25 +0200
commit735726b00fd80848fb4fae68190217688b0ba3de (patch)
tree631c334d812c885d5c1e28888404772985226ca5
downloadaur-735726b00fd80848fb4fae68190217688b0ba3de.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a20170db3f77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = frameworkintegration-git
+ pkgdesc = Framework providing components to allow applications to integrate with a KDE Workspace
+ pkgver = r167.805ad18
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/frameworkintegration
+ arch = i686
+ arch = x86_64
+ groups = kf5
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ depends = kio-git
+ depends = ttf-oxygen
+ depends = libxcursor
+ provides = frameworkintegration
+ conflicts = frameworkintegration
+ source = git://anongit.kde.org/frameworkintegration.git
+ md5sums = SKIP
+
+pkgname = frameworkintegration-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae9658636491
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=frameworkintegration-git
+pkgver=r167.805ad18
+pkgrel=1
+pkgdesc='Framework providing components to allow applications to integrate with a KDE Workspace'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/frameworks/frameworkintegration'
+license=('LGPL')
+depends=('kio-git' 'ttf-oxygen' 'libxcursor')
+makedepends=('extra-cmake-modules-git' 'git')
+groups=('kf5')
+conflicts=(frameworkintegration)
+provides=(frameworkintegration)
+source=('git://anongit.kde.org/frameworkintegration.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd frameworkintegration
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../frameworkintegration \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}