summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-27 15:59:12 +0200
committerGoliathLabs2020-05-27 15:59:12 +0200
commitf2a274ea5c8003adfde75a8f2823dd0ef75bd5a7 (patch)
treeb85a1a03a30db1598a7c0c22121b7cb48a33fcb3
parent454aaab667644a451cd026c3b9b57161953ce319 (diff)
downloadaur-f2a274ea5c8003adfde75a8f2823dd0ef75bd5a7.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 28 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a524a1af9ed..a4ec83090cbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = frameworkintegration-git
pkgdesc = Framework providing components to allow applications to integrate with a KDE Workspace
- pkgver = r234.3ebe689
+ pkgver = r519.b8098a8
pkgrel = 1
- url = https://projects.kde.org/projects/frameworks/frameworkintegration
+ url = https://community.kde.org/Frameworks
arch = i686
arch = x86_64
groups = kf5
license = LGPL
- makedepends = extra-cmake-modules-git
+ makedepends = extra-cmake-modules
+ makedepends = appstream-qt
makedepends = git
- depends = kio-git
- depends = noto-fonts
- depends = libxcursor
+ makedepends = packagekit-qt5
+ depends = kpackage
+ depends = knewstuff
provides = frameworkintegration
conflicts = frameworkintegration
- source = git://anongit.kde.org/frameworkintegration.git
- md5sums = SKIP
+ source = git+https://github.com/KDE/frameworkintegration.git
+ sha256sums = SKIP
pkgname = frameworkintegration-git
diff --git a/PKGBUILD b/PKGBUILD
index d0f520e18832..0f6918ba48b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
-pkgname=frameworkintegration-git
-pkgver=r234.3ebe689
+_pkgname=frameworkintegration
+pkgname=$_pkgname-git
+pkgver=r519.b8098a8
pkgrel=1
pkgdesc='Framework providing components to allow applications to integrate with a KDE Workspace'
arch=('i686' 'x86_64')
-url='https://projects.kde.org/projects/frameworks/frameworkintegration'
+url='https://community.kde.org/Frameworks'
license=('LGPL')
-depends=('kio-git' 'noto-fonts' 'libxcursor')
-makedepends=('extra-cmake-modules-git' 'git')
+depends=(kpackage knewstuff)
+makedepends=(extra-cmake-modules appstream-qt git packagekit-qt5)
groups=('kf5')
-conflicts=(frameworkintegration)
-provides=(frameworkintegration)
-source=('git://anongit.kde.org/frameworkintegration.git')
-md5sums=('SKIP')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+source=("git+https://github.com/KDE/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
- cd frameworkintegration
+ cd $srcdir/$_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
+ cd $srcdir/$_pkgname
mkdir -p build
}
build() {
- cd build
- cmake ../frameworkintegration \
+ cd $srcdir/$_pkgname/build
+ cmake ../ \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
}
package() {
- cd build
+ cd $srcdir/$_pkgname/build
make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING.LIB "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}