summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-10-18 16:14:30 +0200
committerbegin-theadventure2023-10-18 16:14:30 +0200
commitbadba953101377112c658694aa426803393e0472 (patch)
treec664c43e22e8a0810d12175e2bb9c741ef77eea8
downloadaur-badba953101377112c658694aa426803393e0472.tar.gz
1.0.1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eac190d7ada3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = francis
+ pkgdesc = Track your time
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://invent.kde.org/utilities/francis
+ arch = x86_64
+ arch = aarch64
+ license = BSD2
+ license = BSD3
+ license = CPPL:0
+ license = GPL3-or-later
+ license = LGPL2-or-later
+ license = LGPL2.1-or-later
+ makedepends = cmake
+ makedepends = git
+ depends = ki18n5
+ depends = kirigami-addons5
+ depends = qt5-networkauth
+ depends = qt5-quickcontrols
+ depends = qt5-svg
+ source = git+https://invent.kde.org/utilities/francis.git#tag=v1.0.1
+ sha256sums = SKIP
+
+pkgname = francis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..467c3ae675c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=francis
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Track your time'
+url="https://invent.kde.org/utilities/francis"
+arch=('x86_64' 'aarch64')
+license=('BSD2' 'BSD3' 'CPPL:0' 'GPL3-or-later' 'LGPL2-or-later' 'LGPL2.1-or-later')
+depends=('ki18n5' 'kirigami-addons5' 'qt5-networkauth' 'qt5-quickcontrols' 'qt5-svg')
+makedepends=('cmake' 'git')
+source=("git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname
+ cmake -B build
+ cmake --build build
+}
+
+package() {
+ cd $pkgname
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ make install
+ install -Dm644 LICENSES/* -t "$pkgdir/usr/share/licenses/$pkgname"
+}