summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-03-31 21:55:06 -0500
committerlmartinez-mirror2021-03-31 21:55:06 -0500
commit97fdd0c2972fd0338cf5e8193f0dffd5092660bd (patch)
tree805a528191b010725bbde09d69628c1b3a55a760
downloadaur-97fdd0c2972fd0338cf5e8193f0dffd5092660bd.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b074ca05a45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = frangipanni-git
+ pkgdesc = Program to convert lines of text into a tree structure
+ pkgver = 0.4.0.r4.gff97e40
+ pkgrel = 1
+ url = https://github.com/birchb1024/frangipanni
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go>=1.15
+ depends = glibc
+ provides = frangipanni
+ conflicts = frangipanni
+ source = frangipanni-git::git+https://github.com/birchb1024/frangipanni
+ md5sums = SKIP
+
+pkgname = frangipanni-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b848fcfc53fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: lmartinez-mirror
+pkgname=frangipanni-git
+pkgver=0.4.0.r4.gff97e40
+pkgrel=1
+pkgdesc="Program to convert lines of text into a tree structure"
+arch=('x86_64')
+url="https://github.com/birchb1024/frangipanni"
+license=('MIT')
+depends=('glibc')
+makedepends=('git' 'go>=1.15')
+provides=('frangipanni')
+conflicts=('frangipanni')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname"
+ go build
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 755 frangipanni -t "$pkgdir/usr/bin"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}