summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2019-03-31 19:58:50 +0200
committerGiovanni Santini2019-03-31 19:58:50 +0200
commit9af8331c4dc92728c649c7ee8fa441f5a1285493 (patch)
tree00b3c63eb5f32f69bb7a0ef4cb2280d07b6aded7
parentae5fd8d3f4e54bfaeb5618f11be967e5f67bbccc (diff)
downloadaur-9af8331c4dc92728c649c7ee8fa441f5a1285493.tar.gz
upgpkg: franz 5.0.1-1
- Version bump. - Check the installed `electron` version, rather than the online one. - Use Git for downloading sources, rather than the tarball - Use `lerna` for downloading npm stuff as upstream does
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de052242374a..3605c7f16f25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = franz
pkgdesc = Free messaging app for services like WhatsApp, Slack, Messenger and many more.
- pkgver = 5.0.0
+ pkgver = 5.0.1
pkgrel = 1
epoch = 1
url = https://meetfranz.com
@@ -11,10 +11,10 @@ pkgbase = franz
makedepends = python2
makedepends = git
depends = electron
- source = franz-5.0.0.tar.gz::https://github.com/meetfranz/franz/archive/v5.0.0.tar.gz
+ source = git+https://github.com/meetfranz/franz#tag=v5.0.1
source = franz.desktop
source = franz.sh
- sha512sums = 459c40cb95e52aa63334d5e880f146a1158a4f046ab4c943169333e46990cb809bd8094fda440033a245a437c0a5f96b088c5455bbfbe8f8a0605edee5ca6fa3
+ sha512sums = SKIP
sha512sums = ef7c06558f60259dd29ead644327a0030c2c26637e51e3ec27a05542efd4752d68a3f4322973f6a90d6658686abce12700a3ad57aff9e517d0c907c952d7a034
sha512sums = 8584507cfc2736f4736637925536b2c06063c59cd943346717633564ae88b64c5eea294c8897f1250812478ed493f54a470501e98e99d084a2ff012dff9671f8
diff --git a/PKGBUILD b/PKGBUILD
index 03651d31299b..46154d168d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
pkgname=franz
-_pkgver=5.0.0
+_pkgver=5.0.1
pkgver=${_pkgver//-/_}
pkgrel=1
# Due to the previous "_beta" naming
@@ -14,10 +14,10 @@ url='https://meetfranz.com'
license=(Apache)
depends=(electron)
makedepends=(npm python2 git)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/meetfranz/$pkgname/archive/v$_pkgver.tar.gz"
+source=("git+https://github.com/meetfranz/$pkgname#tag=v$_pkgver"
'franz.desktop'
'franz.sh')
-sha512sums=('459c40cb95e52aa63334d5e880f146a1158a4f046ab4c943169333e46990cb809bd8094fda440033a245a437c0a5f96b088c5455bbfbe8f8a0605edee5ca6fa3'
+sha512sums=('SKIP'
'ef7c06558f60259dd29ead644327a0030c2c26637e51e3ec27a05542efd4752d68a3f4322973f6a90d6658686abce12700a3ad57aff9e517d0c907c952d7a034'
'8584507cfc2736f4736637925536b2c06063c59cd943346717633564ae88b64c5eea294c8897f1250812478ed493f54a470501e98e99d084a2ff012dff9671f8')
@@ -27,7 +27,7 @@ prepare() {
ln -s `which python2` python2_path/python
# Small patching
- cd $pkgname-$_pkgver
+ cd $pkgname
# Prevent franz from being launched in dev mode
sed -i "s|export const isDevMode = .*|export const isDevMode = false;|g" \
@@ -36,25 +36,25 @@ prepare() {
src/index.js
# Adjust the electron version to use when building
- electron_version="`curl -s https://git.archlinux.org/svntogit/community.git/plain/trunk/PKGBUILD?h=packages/electron | \
- grep pkgver= | cut -d '=' -f 2`"
+ electron_version="`pacman -Qs electron | grep electron | cut -d' ' -f2 | cut -d'-' -f1`"
sed -i "s|\(\s\+\"electron\":\).*,|\1 \"$electron_version\",|" package.json
}
build() {
- cd $pkgname-$_pkgver
+ cd $pkgname
# Better configuration for npm cache and calling installed binaries
export npm_config_cache="$srcdir"/npm_cache
- export PATH="$srcdir/$pkgname-$_pkgver/node_modules/.bin:$srcdir/python2_path:$PATH"
+ export PATH="$srcdir/$pkgname/node_modules/.bin:$srcdir/python2_path:$PATH"
- npm install
+ npm install lerna
+ lerna bootstrap
gulp build
electron-builder --linux dir
}
package() {
- cd $pkgname-$_pkgver
+ cd $pkgname
# Install the .asar files
install -dm 755 "$pkgdir"/usr/lib/$pkgname