summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-27 17:12:32 +0800
committerzxp198210052023-11-27 17:12:32 +0800
commit498fa314979ea13487621c49920fdc190a105e35 (patch)
tree35f8abdb50343dd5edb571779778efee2339db05
parent9294f0991f2834cd50cf47247c3c56c96325946f (diff)
downloadaur-498fa314979ea13487621c49920fdc190a105e35.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
-rw-r--r--frappe-books.sh5
3 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87e798352b92..8d2a1ece898f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = frappe-books-bin
pkgdesc = Modern desktop accounting for freelancers and small-businesses.
pkgver = 0.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://frappebooks.com/
arch = x86_64
license = AGPL3
- depends = electron18-bin
+ depends = electron18
depends = hicolor-icon-theme
- depends = bash
- depends = gcc-libs
- depends = glibc
provides = frappe-books=0.19.0
conflicts = frappe-books
conflicts = frappebooks
source = frappe-books-0.19.0.deb::https://github.com/frappe/books/releases/download/v0.19.0/frappe-books_0.19.0_amd64.deb
source = frappe-books.sh
sha256sums = 28aeb88e77b59dc19d01cbe8ddf1f026b818d20fc0585496ea18561771b00ef4
- sha256sums = 979fa8d61b7c359499ea139044294bfcfe96d59afdb534cd3b03eddf9d6e97b0
+ sha256sums = 75f0ea8a4e397ca040ccb395ac60d1d19539bae1c197c536cc26a7966cb07bd3
pkgname = frappe-books-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7460b7734704..823df588219d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,39 @@
pkgname=frappe-books-bin
_appname="Frappe Books"
pkgver=0.19.0
-pkgrel=1
+pkgrel=2
pkgdesc="Modern desktop accounting for freelancers and small-businesses."
arch=('x86_64')
url="https://frappebooks.com/"
-_githuburl="https://github.com/frappe/books"
+_ghurl="https://github.com/frappe/books"
license=('AGPL3')
provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}" "frappebooks")
-depends=('electron18-bin' 'hicolor-icon-theme' 'bash' 'gcc-libs' 'glibc')
-makededpends=('asar')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "${pkgname%-bin}.sh")
+conflicts=(
+ "${pkgname%-bin}"
+ "frappebooks"
+)
+depends=(
+ 'electron18'
+ 'hicolor-icon-theme'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('28aeb88e77b59dc19d01cbe8ddf1f026b818d20fc0585496ea18561771b00ef4'
- '979fa8d61b7c359499ea139044294bfcfe96d59afdb534cd3b03eddf9d6e97b0')
+ '75f0ea8a4e397ca040ccb395ac60d1d19539bae1c197c536cc26a7966cb07bd3')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
- asar e "${srcdir}/opt/${_appname}/resources/app.asar" "${srcdir}/opt/${_appname}/resources/app.asar.unpacked"
- asar p "${srcdir}/opt/${_appname}/resources/app.asar.unpacked" "${srcdir}/app.asar"
sed "s|\"/opt/${_appname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g;s|Finance|Finance;Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
- install -Dm644 "${srcdir}/opt/${_appname}/templates/"*.html -t "${pkgdir}/opt/${pkgname%-bin}/templates"
- install -Dm644 "${srcdir}/opt/${_appname}/translations/"*.csv -t "${pkgdir}/opt/${pkgname%-bin}/translations"
- install -Dm644 "${srcdir}/opt/${_appname}/creds/log_creds.txt" -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}/resources"
+ cp -r "${srcdir}/opt/${_appname}/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}/resources"
+ cp -r "${srcdir}/opt/${_appname}/templates" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_appname}/translations" -t "${pkgdir}/usr/lib//${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_appname}/creds/log_creds.txt" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/opt/${_appname}/swiftshader/"*.so -t "${pkgdir}/opt/${pkgname%-bin}/swiftshader"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
diff --git a/frappe-books.sh b/frappe-books.sh
index e74c979ca432..005c6e8dd854 100644
--- a/frappe-books.sh
+++ b/frappe-books.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron18
-_ASAR="/opt/frappe-books/resources/app.asar"
+APPDIR="/usr/lib/frappe-books"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else