summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-11 17:48:34 +0800
committerzxp198210052023-08-11 17:48:34 +0800
commit7e4dc1303afefac05ed374a02dc7be2d22159aa5 (patch)
treec21d39c3de6eda54f84ab07eb3cb94052e36e18c
parent49acb95250d752a4585c2d756b9c20623d33633f (diff)
downloadaur-7e4dc1303afefac05ed374a02dc7be2d22159aa5.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5300c729c3..9f15eb638702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frappe-books-bin
pkgdesc = Modern desktop accounting for freelancers and small-businesses.
pkgver = 0.17.1
- pkgrel = 1
+ pkgrel = 2
url = https://frappebooks.com/
arch = x86_64
license = AGPL3
@@ -10,7 +10,7 @@ pkgbase = frappe-books-bin
depends = bash
depends = gcc-libs
depends = glibc
- provides = frappe-books
+ provides = frappe-books=0.17.1
conflicts = frappe-books
conflicts = frappebooks
source = frappe-books-0.17.1.deb::https://github.com/frappe/books/releases/download/v0.17.1/frappe-books_0.17.1_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index c0b44e7a4b44..38c3e74aadcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="frappe-books-bin"
+pkgname=frappe-books-bin
+_appname="Frappe Books"
pkgver=0.17.1
-pkgrel=1
+pkgrel=2
pkgdesc="Modern desktop accounting for freelancers and small-businesses."
arch=('x86_64')
url="https://frappebooks.com/"
_githuburl="https://github.com/frappe/books"
license=('AGPL3')
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}" "frappebooks")
-provides=("${pkgname%-bin}")
depends=('electron18' 'hicolor-icon-theme' 'bash' 'gcc-libs' 'glibc')
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh")
@@ -17,8 +18,8 @@ sha256sums=('0a7f95319fbc46510bef23ff1ee67b310f743243a5050e01349e288291e82493'
package() {
bsdtar -xf "${srcdir}/data.tar.xz"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/opt/Frappe Books/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
- sed "s|\"/opt/Frappe Books/${pkgname%-bin}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Finance|Finance;Utility|g" \
+ cp -r "${srcdir}/opt/${_appname}/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ sed "s|\"/opt/${_appname}/${pkgname%-bin}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Finance|Finance;Utility|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do